pyspi.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19073 09f5bf6611e6
child 9089 13364585499f
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package pyspi
#
# includes module(s): pyspi
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: laca
#
%define pythonver 2.4

Name:         pyspi
License:      LGPL
Group:        Development/Languages/Python
Version:      0.6.1
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Python bindings for CSPI
Source:       http://people.redhat.com/zcerza/dogtail/releases/%{name}-%{version}.tar.gz
# date:2006-10-07 owner:yippi type:bug
# can get rid of this when Xorg 7.2 integrates?
Patch1:       pyspi-01-solaris.diff
URL:          http://gnome.org/projects/pyspi
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  off
Prereq:       /sbin/ldconfig
Requires:      python >= %{pythonver}
Requires:      at-spi
Requires:      Pyrex
BuildRequires: python-devel >= %{pythonver}
BuildRequires: at-spi-devel

%description
Python bindings for CSPI

%prep
%setup -q
%patch1 -p1

%build
make

%install
python setup.py install --prefix=$RPM_BUILD_ROOT%{_prefix}

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages

%changelog
* Thu Nov 09 2006 - [email protected]
- Bump to 0.6.1.

* Sat Oct 07 2006 - [email protected]
- Bump to 0.6.0.  Add patch to allow building on Solaris.

* Fri Aug 25 2006 - [email protected]
- Bump to 0.5.5.

* Thu May 04 2006 - [email protected]
- Bump to 0.5.4

* Tue Jan 17 2006 - [email protected]
- Bump to 0.5.3.

* Thu Oct 27 2005 - [email protected]
- move from site-packages to vendor-packages

* Mon Oct 24 2005 - [email protected]
- Include .pyc files. A Google search indicates that most people include them.

* Thu Oct 20 2005 - [email protected]
- Remove 'make' call from %install. Already in '%build'.
- Delete .pyc files so they are not included in the package.

* Wed Oct 19 2005 - [email protected]
- Initial version.