quick-lounge-applet.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 8474 fb6441c8ea9b
child 9017 25e7c91bd206
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package quick-lounge-applet
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
# Owner: gman
#
Name:         quick-lounge-applet
License:      GPL
Group:        Productivity/Graphics/Viewers
Version:      2.12.1
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Quick Lounge Panel Applet
Source:       http://ftp.gnome.org/pub/GNOME/sources/quick-lounge-applet/2.12/%{name}-%{version}.tar.bz2
#owner:gman date:2006-11-02 type:bug bugzilla:369265
Patch1:       quick-lounge-applet-01-xlibs.diff
#owner:gman date:2006-10-12 type:bug bugzilla:369103
Patch2:       quick-lounge-applet-02-launch-default-help.diff
#owner:gman date:2006-10-12 type:bug bugster:6435439 bugzilla:319050
Patch3:       quick-lounge-applet-03-multihead-fix.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/quick-lounge-applet
Autoreqprov:  on

%define gnome_vfs_version 2.4.0
%define libgnome_version 2.4.0
%define libgnomeui_version 2.4.0.1
%define gnome_panel_version 2.4.0
%define gnome_desktop_version 2.4.0
%define gnome_menus_version 2.12.0

Requires:      gnome-vfs >= %{gnome_vfs_version}
Requires:      libgnome >= %{libgnome_version}
Requires:      libgnomeui >= %{libgnomeui_version}
Requires:      gnome-panel >= %{gnome_panel_version}
Requires:      gnome-desktop >= %{gnome_desktop_version}
Requires:      gnome-menus >= %{gnome_menus_version}
BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: libgnome-devel >= %{libgnome_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires: gnome-menus-devel >= %{gnome_menus_version}

%description
Quick Lounge Applet allows you to group launchers on your panel.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --libexecdir=%{_libexecdir} \
    --localstatedir=/var/lib
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL  

rm -rf $RPM_BUILD_ROOT/var


%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="quick-lounge.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done


%files
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_datadir}/pixmaps/*.png
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/gnome-2.0/ui/*
%{_datadir}/quick-lounge/*
%{_sysconfdir}/gconf/schemas/*.schemas
%{_libdir}/bonobo/servers/*
%{_datadir}/gnome/help/quick-lounge/*
%{_datadir}/omf/%{name}/*.omf
%{_libexecdir}/*

%changelog
* Fri Oct 12 2006 - [email protected]
- Add patch to fix bugzilla #319050 and other issues on 
  multihead/xinerama.

* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff

* Tue Nov 29 2005 - [email protected]
- Bump to 2.12.1.

* Sun Sep 18 2005 - [email protected]
- Fix up the help patch so we build.

* Tue Aug 30 2005 - [email protected]
- Add patch to build against newer gmenu

* Tue Aug 30 2005 - [email protected]
- Add gnome-menus dependency.

* Tue Aug 16 2005 - [email protected]
- Bump to 2.10.1.

* Thu Jun 16 2005 - [email protected]
- Bump to 2.10.1 Remove/Add/Realign patches

* Wed Feb 02 2005 - [email protected]
- Added quick-lounge-applet-09-help-from-launcher-dialog.diff
  to launch help when user clicks on the help button in the "Add Launcher"
  dialog.
 
* Thu Jan 20 2005 - [email protected]
- Added quick-lounge-applet-08-launch_default_help.diff
  to make sure that default help gets launched, not always yelp.
  Fixes bug #5097716

* Wed Jan 19 2005 - [email protected]
- Added quick-lounge-applet-07-min_max_update.diff to
  set the minimum and maximum values properly in the 
  preferences dialog. Fixes Bug #5028045.
  committing on behalf of [email protected]

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Mon Sep 20 2004 [email protected]
- Added quick-lounge-applet-05-g11n-alllinguas.diff to support hu

* Wed Aug 25 2004 [email protected]
- Updated l10n help tarball name for Cinnabar

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Mon Jul 19 2004 - [email protected]
- synced with HEAD, fixed up packaging

* Thu Jul 08 2004 - [email protected]
- fixed typo in patch 04 (p->P)

* Thu Jul 08 2004 - [email protected]
- fixed typo in patch 04 (p->P)

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 25 2004 - [email protected]
- Add patch from Vinay M R  to fix quicklounge to be usable as root 

* Wed Jun 23 2004 - [email protected]
- Add patch from Vinay M R  to fix the properites dialog crash

* Wed Jun 09 2004 - [email protected]
- Remove l10n online help patch(#2). Changes are now included in base source.

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to quick-lounge-applet-l10n-po-1.1.tar.bz2

* Fri Apr 30 2004 - [email protected]
- add libexecdir to %files.  

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Wed Apr 07 2004 - [email protected]
- add patch 03 to add the Xlibs to LDFLAGS.
- add --libexecdir=%{_libexecdir} to configure args
* Tue Apr 06 2004 - [email protected]
- Remove *.so* from files, as none delivered anymore

* Tue Apr 06 2004 - [email protected]
- Forgot to rename patches in spec file

* Mon Apr 05 2004 - [email protected]
- Bump to 2.1.1
- Remove 3 patches and re-align the remaining two

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to quick-lounge-applet-l10n-po-1.0.tar.bz2

* Thu Mar 04 2004 - <[email protected]>
- Added quick-lounge-applet-05-display-help.diff to display help with 
  correct section id.

* Thu Feb 05 2004 - <[email protected]>
- Upgrade tarball to 2.0.3 for Cinnabar, add l10n docs/help

* Fri Jan 09 2004 - <[email protected]>
- Patch for deprecated widgets compiling

* Tue Oct 14 2003 - <[email protected]>
- Upgrade tarball to 2.0.1 for QS

* Wed Oct 01 2003 - <[email protected]>
- #4930772 and #4930772

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Jun 30 2003 - Glynn Foster <[email protected]>
- Add in the bonobo ui xml menus to the %files directive

* Wed May 15 2003 - Glynn Foster <[email protected]>
- initial Sun release