vino.spec
author dcarbery
Fri, 24 Nov 2006 16:37:59 +0000
branch217update
changeset 19096 d542fc2c823e
parent 19083 3cfcf4126ea8
permissions -rw-r--r--
Merged trunk changes r9797:9829 into 217update branch.

#
# spec file for package vino
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: halton
#
Name:			vino
License:		GPL
Group:			System/GUI/GNOME
Version:		2.17.2
Release:		2
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		GNOME Remote Desktop
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.17/%{name}-%{version}.tar.bz2
Patch1:                 vino-01-fix-a11y-hang.diff
# date:2006-11-16 bugster:6493868 owner:halton type:bugfix
Patch2:                 vino-02-disable-xsun.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		on

%define			gnutls_version 0.9.5
%define			gtk2_version 2.2.0
%define			GConf_version 2.2.0
%define			libglade_version 2.0.0
%define                 intltool_version 0.25
%define			libgnomeui_version 2.4.0

Requires:		gnutls         >= %{gnutls_version}
Requires:		gtk2           >= %{gtk2_version}
Requires:		GConf          >= %{GConf_version}
Requires:		libglade       >= %{libglade_version}
Requires:		libgnomeui     >= %{libgnomeui_version}
BuildRequires:		gnutls-devel   >= %{gnutls_version}
BuildRequires:		gtk2-devel     >= %{gtk2_version}
BuildRequires:		GConf-devel    >= %{GConf_version}
BuildRequires:		libglade-devel >= %{libglade_version}
BuildRequires:		intltool       >= %{intltool_version}

%description
Vino is an integrated GNOME VNC server and a VNC client written in Java.


%prep
%setup -q
%patch1 -p1
%patch2 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
libtoolize --force
intltoolize --force --automake
autoheader
automake -a -f -c --gnu
autoconf 

CFLAGS="$RPM_OPT_FLAGS"					\
./configure   --prefix=%{_prefix}			\
	      --sysconfdir=%{_sysconfdir}		\
	      --libexecdir=%{_libexecdir}		\
	      --enable-session-support=yes		\
	      --enable-http-server=yes			\
	      --enable-gnome-keyring=yes		\
	      --enable-ipv6=yes

make -j $CPUS


%install
rm -rf $RPM_BUILD_ROOT

export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL


%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/vino-server.schemas >/dev/null

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%doc docs/remote-desktop.txt
%doc docs/TODO
%{_bindir}/*
%{_libdir}/bonobo/servers/*
%{_libexecdir}/*
%{_datadir}/applications/
%{_datadir}/gnome/vino/*
%{_datadir}/icons/
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%config %{_sysconfdir}/gconf/schemas/*

%changelog
* Thu Nov 23 2006 - [email protected]
- Remove upstream patches, 02-a11y-theme-icons and 03-a11y-selectable-label. 
  Renumber remainder.

* Thu Nov 23 2006 - [email protected]
- Bump to 2.17.2. Remove 8 upstream patches: 02-gnome-keyring, 03-xgl,
  04-ipv6-remove-dead-code, 05-ipv6-use-getaddrinfo, 06-ipv6-use-inet-ntop,
  07-ipv6-configure-check, 08-ipv6-create-ipv6-socket,
  09-ipv6-create-ipv6-http-socket.

* Fri Nov 17 2006 - [email protected]
- Change patch owner to opensolaris id.

* Thu Nov 16 2006 - [email protected]
- Add patch disable-xsun.diff.

* Wed Nov 08 2006 - [email protected]
- Add patch a11y-theme-icons.diff to fix bug
  bugster:6491224 bugzilla:345394
- Add patch a11y-selectable-label.diff to fix bug
  bugster:6491221 bugzilla:338043

* Tue Nov 07 2006 - [email protected]
- Remove glib-gettextize because intltoolize added.
- Enable ipv6-create-ipv6-socket.diff and 
  ipv6-create-ipv6-http-socket.diff to fix ipv6 problem, 
  bugster #6483870, bugzilla #310965.

* Fri Nov 03 2006 - [email protected]
- Add autoheader before configure to fix ipv6 and gnome-keyring.

* Fri Oct 27 2006 - [email protected]
- Change IPv6 patch according community new patch
- Add configure option --enable-ipv6=yes

* Thu Oct 19 2006 - [email protected]
- Rename patch keyring.diff to gnome-keyring.diff
- Add option --enable-gnome-keyring.
- Add patch ipv6-support.diff to support IPv6, #6483870.

* Tue Oct 17 2006 - [email protected]
- Add patch xgl.diff to fix sparc crash bug #6409721.

* Tue Oct 17 2006 - [email protected]
- Bump to 2.16.0.

* Wed Oct 11 2006 - [email protected]
- Remove Patch2 vino-02-libgnomeui-include.diff and reorder,
  since patch1 already fix this problem.

* Fri Jan 20 2006 - [email protected]
- Bump to 2.13.5.

* Fri Sep 30 2005 - [email protected]
- Add patch to move a #include outside '#ifdef HAVE_GNUTLS' code so that it
  builds. Bugzilla: 315459.

* Sun Sep 18 2005 - [email protected]
- Remove the resolution-change patch, and reorder.

* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Tue Aug 23 2005 - [email protected]
- Remove PATH setting as it is not used (info was wrong and build unaffected).

* Tue Aug 16 2005 - [email protected]
- Bump to 2.11.90.

* Thu May 26 2005 - [email protected]
- Bump to 2.10.1

* Fri May 20 2005 - [email protected]
- Added vino-08-fix-a11y-hang.diff to fix the gnome-session hang
  with a11y and remote desktop enabled. Fixes bug #6272397.

* Wed Mar 02 2005 - [email protected]
- Added vino-07-allow-resolution-change.diff to fix the crash when
  trying to change resolution from the client. Fixes bug #4965618.

* Thu Sep 16 2004 - [email protected]
* Added vino-05-g11n-alllinguas.diff to include cs,hu linguas

* Thu Aug 26 2004 - [email protected]
- Help invocation for vino is implemented.
 
* Thu Jul 08 2004 - [email protected]
- Updated l10n content to vino-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Sun May 30 2004 - [email protected]
- New JDK

* Wed May 14 2004 - [email protected]
- added vino-03-fix-stdint.diff to fix build error on S9

* Wed May 12 2004 - [email protected]
- Updated l10n content to vino-l10n-po-1.1.tar.bz2

* Thu Apr 14 2004 - [email protected]
- Add ACLOCAL_FLAGS to aclocal call for Solaris build.

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to vino-l10n-po-1.0.tar.bz2

* Wed Feb 11 2004 - <[email protected]>
- Update to 0.14 + port

* Thu Nov 06 2003 - <[email protected]>
- Initial spec file