SUNWdesktop-cache.spec
author ginnchen
Mon, 12 Apr 2010 08:07:21 +0000
branchgnome-2-28
changeset 18675 d625b72c91d8
parent 16434 f21f22550fe9
child 17851 2a9662e48aca
permissions -rw-r--r--
2010-04-12 Ginn Chen <[email protected]> * SUNWfirefox.spec: Fix the build issue of Firefox 3.6.3.

#
# spec file for package SUNWdesktop-cache
#
# includes module(s): desktop-cache
#
%define owner erwannc

%include Solaris.inc

%define OSR Developed in open, OSR not needed:0

Name:         SUNWdesktop-cache
License:      Other
Group:        System/Libraries
Version:      0.2.2
Summary:      desktop-cache is a set of SMF services used to update the various GNOME desktop caches.
Source:       http://dlc.sun.com/osol/jds/downloads/extras/desktop-cache/desktop-cache-smf-services-%{version}.tar.bz2
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
SUNW_BaseDir: %{_basedir}
SUNW_Copyright: %{name}.copyright
%include default-depend.inc
Requires: SUNWdesktop-cache-root
Requires: SUNWPython

%package root
Summary:      %{summary} - / filesystem
SUNW_BaseDir: /
%include default-depend.inc

%prep
%setup -q -n desktop-cache-smf-services-%version

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

./configure --libdir=/lib \
            --datadir=/usr/share \
	    --sysconfdir=/var
make -j $CPUS

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%doc README AUTHORS
%doc(bzip2) COPYING NEWS ChangeLog
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/doc
%defattr (-, root, bin)
%{_datadir}/desktop-cache

%files root
%attr (-, root, sys) %class (manifest) /var/svc/manifest
%defattr (-, root, bin)
%dir %attr (0755, root, bin) /lib
/lib/svc
%defattr (-, root, sys)


%changelog
* Wed Jun  3 2009 - [email protected]
- add Python dependency for find_newer
* Thu May 21 2009 - [email protected]
- bump to 0.2.2
* Wed Apr 29 2009 - [email protected]
- bump to 0.2.1
- delete gnome-vfs and gconf dependencies to break circular dep
* Thu Apr  2 2009 - [email protected]
- bump to 0.2.0
* Mon Mar 23 2009 - [email protected]
- Since /lib/svc/method/gconf-cache (SUNWdesktop-cache) requires
  /usr/bin/gconftool-2 which is found in SUNWgnome-config, add the
  dependency.
- Since /lib/svc/method/icon-cache (SUNWdesktop-cache) requires
  /usr/bin/gtk-update-icon-cache which is found in SUNWgnome-base-libs,
  add the dependency.
- Since /lib/svc/method/mime-types-cache (SUNWdesktop-cache) requires
  /usr/bin/update-mime-database which is found in SUNWgnome-vfs, add
  the dependency.
* Wed Feb 02 2009 - [email protected]
- uprev tarball to 0.1.6 which contain fix to d.o.o #2399 
  tarball version 0.1.4 and 0.1.5 are bad fixes.
* Wed Sep 17 2008 - [email protected]
- uprev tarball to 0.1.2 to incldue CDDL COPYING file. add %doc to %files.
  Leave Laca's patch untouched to avoid having to roll another tarball when
  bug is fixed.
* Sat Jun 28 2008 - [email protected]
- add patch stability.diff that updates the stability classification
  in the manifests until smf's dtd is updated to the new interface
  taxonomy.
* Fri Jun 27 2008 - [email protected]
- bump to 0.1.1
* Thu Jun 5 2008 - [email protected]
- fix %files and delete unnecessary autotools to speed up build
* Tue Jun 3 2008 - [email protected]
- Initial spec