SUNWdia.spec
author ginnchen
Mon, 12 Apr 2010 08:07:21 +0000
branchgnome-2-28
changeset 18675 d625b72c91d8
parent 16907 c6ddec838f33
child 17427 a486adb4f341
permissions -rw-r--r--
2010-04-12 Ginn Chen <[email protected]> * SUNWfirefox.spec: Fix the build issue of Firefox 3.6.3.

#
# spec file for package SUNWdia
#
# includes module(s): dia
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner jerrytan
#
%include Solaris.inc
%use dia = dia.spec

Name:             SUNWdia
Summary:          Dia Diagram Editor
Source:           %{name}-manpages-0.1.tar.gz
Version:          %{dia.version}
SUNW_BaseDir:     %{_basedir}
SUNW_Copyright:   %{name}.copyright
BuildRoot:        %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlibart
Requires: SUNWgtk2
Requires: SUNWgnome-libs
Requires: SUNWgccruntime
BuildRequires: SUNWgtk2-devel
BuildRequires: SUNWgccruntime

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir -p %name-%version
%dia.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
%dia.build -d %name-%version

%install
%dia.install -d %name-%version

rm -r $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%if %build_l10n
%else
# REMOVE l10n FILES
#FIXME: really need to fix this stuff up
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/eu
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/[a-d]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/dia/[f-z]*
%endif

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16/apps
%{_datadir}/icons/hicolor/16x16/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22/apps
%{_datadir}/icons/hicolor/22x22/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
%{_datadir}/icons/hicolor/24x24/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32/apps
%{_datadir}/icons/hicolor/32x32/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48/apps
%{_datadir}/icons/hicolor/48x48/apps/dia.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
%{_datadir}/icons/hicolor/scalable/apps/dia.svg
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/dia/C
%{_datadir}/gnome/help/dia/en
%{_datadir}/man/*
%dir %attr (0755, root, other) %{_datadir}/mime-info
%{_datadir}/mime-info/*
%{_datadir}/omf/*
%dir %attr (0755, root, other) %{_datadir}/dia
%{_datadir}/dia/*
%doc -d dia-%{dia.version} AUTHORS README
%doc(bzip2) -d dia-%{dia.version} COPYING ChangeLog NEWS po/ChangeLog
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/dia/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/dia/eu
# Comment this line out since no [a-d]* locale at this point
#%{_datadir}/gnome/help/dia/[a-d]*
%{_datadir}/gnome/help/dia/[f-z]*
%endif

%changelog
* Wed Oct 22 2008 - [email protected]
- Created