SUNWgnome-help-viewer.spec
author fujiwara
Mon, 04 Jun 2007 04:54:45 +0000
changeset 9979 d6dceca0870c
parent 9973 6ca359e1e2ad
child 10241 a02843d1cbca
permissions -rw-r--r--
2007-06-04 Takao Fujiwara <[email protected]> * SUNWgnome-help-viewer.spec: * SUNWgnome-libs.spec: Updated to move scrollkeeper-rebuilddb

#
# spec file for package SUNWgnome-help-viewer
#
# includes module(s): yelp
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc

%use yelp = yelp.spec

Name:                    SUNWgnome-help-viewer
Summary:                 GNOME help system
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires:	SUNWgnome-doc-utils
Requires:	SUNWgnome-libs
Requires:       SUNWgnome-vfs
Requires:       SUNWgnome-component
Requires:       SUNWgnome-base-libs
Requires:       SUNWgnome-config
Requires:       SUNWlxml
Requires:       SUNWlxsl
Requires:  	SUNWfirefox
Requires:       SUNWbzip
Requires:       SUNWgnome-print
Requires:       SUNWlibC
Requires:       SUNWlibpopt
Requires:       SUNWxwrtl
Requires:       SUNWzlib
Requires:       SUNWpostrun
BuildRequires:  SUNWgnome-print-devel
BuildRequires:  SUNWlibpopt-devel
BuildRequires:  SUNWfirefox-devel
BuildRequires:  SUNWgnome-print-devel
BuildRequires:  SUNWgnome-vfs-devel
BuildRequires:  SUNWgnome-component-devel
BuildRequires:  SUNWgnome-libs-devel
BuildRequires:  SUNWgnome-base-libs-devel
BuildRequires:  SUNWgnome-config-devel
BuildRequires:  SUNWgnome-doc-utils-devel
BuildRequires:  SUNWlxml
BuildRequires:  SUNWlxsl

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%yelp.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -


%build
export CFLAGS="%optflags -I/usr/sfw/include -I/usr/sfw/include/freetype2 -I%{_includedir}/mps -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
export CXXFLAGS="%cxx_optflags -I%{_includedir}/mps"
export PKG_CONFIG_PATH=%{_pkg_config_path}:/usr/sfw/lib/pkgconfig
#FIXME: freetype2.m4?
export ACLOCAL_FLAGS="-I ./m4 -I /usr/sfw/share/aclocal"
export LDFLAGS="-z ignore -z combreloc -Bdirect -norunpath"

%yelp.build -d %name-%version

%install
%yelp.install -d %name-%version
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

# TODO: Should we keep the gconf files?
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%attr (-, root, other) %{_datadir}/icons
%{_datadir}/yelp
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Wed Jul 26 2006 - [email protected]
- Bump to 2.15.5, update %files, bonobo support has been removed.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Sat May 13 2006 - [email protected]
- Remove /usr/lib/jds-private from LDFLAGS
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Jan 05 2006 - [email protected]
- Complete the Build/Requires lists.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Fri Sep 30 2005 - [email protected]
- Add icons dir to %files; remove /etc dir before packaging.
* Thu Jul 21 2005 - [email protected]
- Add SUNWmozilla dependency as configure breaking without mozilla.
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Wed Aug 18 2004 - [email protected]
- Change manpage perms for Solaris integration.
* Fri Jul 09 2004 - [email protected]
- Return -R to LDFLAGS. I had incorrectly implemented the ARC decision.
* Thu Jul 08 2004 - [email protected]
- Remove -R from LDFLAGS because ARC said to use -norunpath.
* Fri Jul 02 2004 - [email protected]
- Add /usr/lib/jds-private to LDFLAGS.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Fri May 14 2004 - [email protected]
- Added libxslt dependency
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Mon Mar 01 2004 - <[email protected]>
- define PERL5LIB.
- remove non-existant dirs from %files share
* Tue Feb 17 2004 - <[email protected]
- initial spec file created