atk.spec
author laca
Fri, 29 Oct 2004 01:28:51 +0000
changeset 4365 d8676a6421af
parent 4276 2a2c7f354601
child 4387 1b0580c5041e
permissions -rw-r--r--
2004-10-29 Laszlo Peter <[email protected]> * GConf.spec, ORBit2.spec, atk.spec, glib2.spec, gtk2.spec, libIDL.spec, libbonobo.spec, libglade.spec, pango.spec: use $CC64 as the 64-bit compiler, if defined

Name:         atk
License:      LGPL
Group:        System/Libraries
Version:      1.7.3
Release:      22
Distribution: Cinnabar
Vendor:	      Sun Microsystems, Inc.
Summary:      ATK - Accesibility Toolkit Libraries
Source:       http://ftp.gnome.org/pub/GNOME/sources/atk/1.7/%{name}-%{version}.tar.bz2
Source1:      atk-l10n-po-1.6.tar.bz2
Source2:      libatk-1.0.3.gz
URL:          http://www.gtk.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
AutoReqProv:  on
Prereq:	      /sbin/ldconfig

%define glib2_version 2.4.0

Requires:      glib2 >= %{glib2_version}
BuildRequires: glib2-devel >= %{glib2_version}

%description
The ATK Library provides a set of interfaces for accesibility. By supporting the ATK interfaces, an application or toolkit can be used with such tools as screen readers, magnifiers, and alternate input devices.

%package devel
Summary:      ATK - Accessibility Toolkit Developer Libraries
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     glib2-devel >= %{glib2_version}

%description devel
The ATK Library provides a set of interfaces for accesibility. By supporting the ATK interfaces, an application or toolkit can be used with such tools as screen readers, magnifiers, and alternate input devices.

%prep
%setup -q
bzcat %SOURCE1 | tar xf -

%ifos solaris
%ifarch amd64 sparcv9
cd ..
cp -rp atk-%{version} atk-%{version}-64
%endif
%endif


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CONFLAGS="--prefix=%{_prefix}"

%ifos solaris

CPUS=$(($CPUS*4))

%ifarch amd64 sparcv9
export CC=${CC64:-$CC}
save_PATH="$PATH"
ccdir=`dirname $CC`
export PATH=$ccdir:$PATH
cd ../atk-%version-64
export CFLAGS="$CFLAGS64"
export LDFLAGS="$LDFLAGS64"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"

./configure $CONFLAGS					\
            --bindir=%{_bindir}/%{_arch64}		\
            --libdir=%{_libdir}/%{_arch64}		\
            --libexecdir=%{_libexecdir}/%{_arch64}	\
            --sysconfdir=%{_sysconfdir}/%{_arch64}	\
	    --disable-gtk-doc

make -j $CPUS
cd ../atk-%version
export CC=${CC32:-$CC}
export PATH="$save_PATH"

export LDFLAGS="$LDFLAGS32"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
export CFLAGS="$CFLAGS32"
export RPM_OPT_FLAGS="$CFLAGS"

%endif
%endif


CFLAGS="$RPM_OPT_FLAGS"			\
./configure $CONFLAGS			\
            --sysconfdir=%{_sysconfdir}	\
	    --enable-gtk-doc
make -j $CPUS

%install

%ifos solaris
%ifarch amd64 sparcv9
cd ../atk-%version-64
make install DESTDIR=$RPM_BUILD_ROOT
cd ../atk-%version
%endif
%endif

make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man3
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post 
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_libdir}/libatk*.so.*

%files devel
%defattr(-, root, root)
%{_includedir}/atk-1.0/*
%{_libdir}/pkgconfig/*.pc
%{_libdir}/libatk*.so
%{_datadir}/gtk-doc/html/atk
%{_mandir}/man3/*

%changelog
* Fri Oct 29 2004 - [email protected]
- use $CC64 for the 64-bit build if defined

* Sat Oct  2 2004 - [email protected]
- Create 64bit libraries for Solaris

* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc.

* Wed Jul 28 2004 - <[email protected]>
- Bump to 1.7.3

* Mon Jul 26 2004 - <[email protected]>
- Bump to 1.7.2

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to atk-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue Jun 08 2004 - <[email protected]>
- Bump to 1.7.1

* Wed May 12 2004 - [email protected]
- Updated l10n content to atk-l10n-po-1.1.tar.bz2

* Thu Apr 22 2004 - <[email protected]>
- Bump to 1.7.0

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to atk-l10n-po-1.0.tar.bz2

* Mon Mar 15 2004 - <[email protected]>
- Change '1.5' in URL to '1.6'.

* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.

* Wed Mar 10 2004 - <[email protected]>
- Bump to 1.6.0

* Wed Feb 18 2004 - <[email protected]>
- Bump to 1.5.4, remove pc patch

* Fri Jan 09 2004 - <[email protected]>
- add patch to fix a broken .pc file
- clean up for Solaris builds

* Mon Dec 15 2003 - <[email protected]>
- upgrade to 1.5.1 tarball

* Mon Oct 6 2003 - <[email protected]>
- upgrade to 1.4 tarball

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Tue May 13 2003 - [email protected]
- initial Sun release