pango.spec
author laca
Fri, 29 Oct 2004 01:28:51 +0000
changeset 4365 d8676a6421af
parent 4276 2a2c7f354601
child 4409 4fec71e58697
permissions -rw-r--r--
2004-10-29 Laszlo Peter <[email protected]> * GConf.spec, ORBit2.spec, atk.spec, glib2.spec, gtk2.spec, libIDL.spec, libbonobo.spec, libglade.spec, pango.spec: use $CC64 as the 64-bit compiler, if defined

Name:         pango
License:      LGPL
Group:        System/Libraries
Version:      1.4.1
Release:      23
Distribution: Cinnabar
Vendor:	      Sun Microsystems, Inc.
Summary:      Library for layout and rendering of internationalized text
Source:       http://ftp.gnome.org/pub/GNOME/sources/pango/1.4/pango-%{version}.tar.bz2
Source1:      pango-querymodules.1.gz
Source2:      libpango-1.0.3.gz
Source3:      libpangoft2-1.0.3.gz
Source4:      libpangox-1.0.3.gz
Patch1:       pango-01-broken-text.diff
Patch2:       pango-02-fullwidth-space.diff
Patch3:       pango-03-disable-script.diff
URL:          http://www.gtk.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define freetype2_version 2.1.3
%define glib2_version 2.4.0
%define pkgconfig_version 0.15.0
%define XFree86_version 4.3.0
%define fontconfig_version 2.2.92

Requires:      freetype2 >= %{freetype2_version}
Requires:      glib2 >= %{glib2_version}
Requires:      XFree86-libs >= %{XFree86_version}
Requires:      fontconfig >= %{fontconfig_version}
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}
BuildRequires: freetype2-devel >= %{freetype2_version}
BuildRequires: XFree86-devel >= %{XFree86_version}

%description
Pango is a library for layout and rendering of text, with an emphasis on internationalization. 
It forms the core of text and font handling in GTK+ 2.0.

%package devel
Summary:      Development Library for layout and rendering of internationalized text
Group:        Development/Libraries
Requires:     %{name} = %{version}-%{release}
Requires:     glib2-devel >= %{glib2_version}
Requires:     freetype2-devel >= %{freetype2_version}
Requires:     XFree86-devel >= %{XFree86_version}

%description devel
Pango is a library for layout and rendering of text, with an emphasis on internationalization. 
It forms the core of text and font handling in GTK+ 2.0.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1

%ifos solaris
%ifarch amd64 sparcv9
cd ..
cp -rp pango-%{version} pango-%{version}-64
%endif
%endif


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CONFLAGS="--prefix=%{_prefix} --mandir=%{_mandir} --with-native-locale=yes \
            --with-xinput=xfree --without-qt"

%ifos solaris
%ifarch amd64 sparcv9
CPUS=$(($CPUS*4))

cd ../pango-%version-64

export CFLAGS="$CFLAGS64"
export LDFLAGS="$LDFLAGS64"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
export CC=${CC64:-$CC}
save_PATH="$PATH"
ccdir=`dirname $CC`
export PATH=$ccdir:$PATH

./configure $CONFLAGS					\
            --bindir=%{_bindir}/%{_arch64}		\
            --libdir=%{_libdir}/%{_arch64}		\
            --libexecdir=%{_libexecdir}/%{_arch64}	\
            --sysconfdir=%{_sysconfdir}/%{_arch64} 	\
	    --disable-gtk-doc

make -j $CPUS

cd ../pango-%version

export CFLAGS="$CFLAGS32"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="$LDFLAGS32"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
export CC=${CC32:-$CC}
export PATH="$save_PATH"

%endif
%endif

./configure $CONFLAGS \
            --sysconfdir=%{_sysconfdir} \
	    --enable-gtk-doc
make -j $CPUS

%install

%ifos solaris
%ifarch amd64 sparcv9
cd ../pango-%version-64
make install DESTDIR=$RPM_BUILD_ROOT
cd ../pango-%version
%endif
%endif

make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man3
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/pango/1.4.0/modules/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/pango.modules

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%{_libdir}/pango/*/*/*.so
%{_libdir}/libpango*-*.so.*
%{_bindir}/pango-querymodules
%{_sysconfdir}/pango/*
%{_mandir}/man1/*

%files devel
%defattr(-, root, root)
%{_libdir}/libpango*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/gtk-doc/html/pango
%{_mandir}/man3/*

%changelog
* Fri Oct 29 2004 - [email protected]
- use $CC64 for the 64-bit build if defined

* Sun Oct 10 2004 - [email protected]
- add patch pango-03-disable-script.diff to fix 5098206
      Latin font should not be used for ASCII when monospace family.
- update patch pango-02-fullwidth-space.diff to fix 5068848
      [Cinnabar] Space width problem in gedit, evolution.

* Sat Oct  2 2004 - [email protected]
- Create 64bit libraries for Solaris

* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc.

* Fri Aug 06 2004 - <[email protected]>
- Removed pango-01-unihan.diff, 1.4.1 fixes the Unihan issue.

* Thu Aug 05 2004 - [email protected]
- Bump to 1.4.1

* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jul 01 2004 - <[email protected]>
- Added patch pango-03-fullwidth-space.diff to fix bug 5067780,
  [Cinnabar] Japanese space chars are corrupt at Sans/Monospace

* Wed Mar 28 2004 - <[email protected]>
- add patch pango-01-unihan.diff to fix 5038959
     Unihan issue should be resolved with current language tag
- add patch pango-02-broken-text.diff to fix 5038972
     pango wouldn't render the legacy encoding string

* Wed Mar 24 2004 - <[email protected]>
- Bump to 1.4.0

* Thu Mar 11 2004 - <[email protected]>
- Bumped to 1.3.6. Remove pua-character patch until it has been properly
  created. We're not keeping broken patches around.

* Tue Mar 02 2004 - <[email protected]>
- Bumped to 1.3.5
- Removed pango-01-fix_pc.diff, not needed anymore.
- Renamed pango-02-pua-character.diff to pango-01-pua-character.diff.

* Tue Feb 24 2004 - <[email protected]>
- Bump to 1.3.2
- Re-Marge patch pango-01-fix_pc.diff
- Port patch pango-02-pua-character.diff from QS, should have been done already

* Fri Jan 09 2004 - <[email protected]>
- add patch to fix a broken .pc file
- clean up for Solaris builds

* Mon Dec 15 2003 - <[email protected]>
- Updating to 1.3.1 tarball

* Mon Oct 06 2003 - <[email protected]> 1.2.5-1
- Updating to 1.2.5 from GNOME 2.4.0.

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Jul 25 2003 - [email protected]
- add XFree86-libs dependency so postinstall script 
  doesn't fail during OS install.

* Wed Jul 09 2003 - [email protected]
- updated to pango 1.2.3

* Tue May 13 2003 - [email protected]
- initial Sun release.