control-center.spec
author gman
Tue, 06 Apr 2004 02:30:12 +0000
changeset 2400 d98f02d21a69
parent 2398 7a29461443c9
child 2479 8866779fa186
permissions -rw-r--r--
2004-04-06 Glynn Foster <[email protected]> * control-center.spec: Bump to 2.6.0.3, still needs work though and polish. * libxklavier.spec: Bump to 1.00 * patches/control-center-01-menu-icon-reorder.diff: Create a single patch for these. * patches/control-center-01-window-icon-themes.diff: Mege. * patches/control-center-02-filetypes-proxy-menu-icon.diff: Merge. * patches/control-center-02-keybindings-close.diff: Rename. * patches/control-center-03-help-links.diff: Rename. * patches/control-center-03-settings-menu-reorder.diff: Merge. * patches/control-center-04-capplet-titles.diff: Remove, it was pointless. * patches/control-center-04-ctrl-alt-del.diff: Rename. * patches/control-center-05-keybindings-close.diff: Remove. * patches/control-center-05-solaris-forte-build.diff: Rename, and update. * patches/control-center-06-g11n-schemas.diff: Update. * patches/control-center-06-help-links.diff: Remove. * patches/control-center-07-ctrl-alt-del.diff: REmove. * patches/control-center-07-g11n-potfiles.diff: Rename, and update. * patches/control-center-08-solaris-forte-build.diff: * patches/control-center-09-g11n-schemas.diff: Remove. * patches/control-center-10-g11n-potfiles.diff: Remove. * patches/libxklavier-01-fix-build.diff: Remove. * patches/libxklavier-01-null-dpy-pointer.diff: Rename. * patches/libxklavier-02-null-dpy-pointer.diff: Remove. * patches/xscreensaver-03-dot-desktop.diff: Use updated icon in gnome-icon-theme.

Name:         control-center
License:      GPL
Group:        System/GUI/GNOME
Version:      2.6.0.3
Release:      1
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      The GNOME control center for GNOME 2.6
Source:       http://ftp.gnome.org/pub/GNOME/sources/control-center/2.6/control-center-%{version}.tar.bz2
Source1:      control-center-l10n-po-1.0.tar.bz2
Source2:      gnome-accessibility-keyboard-properties.1.gz
Source3:      gnome-background-properties.1.gz
Source4:      gnome-control-center.1.gz
Source5:      gnome-default-applications-properties.1.gz
Source6:      gnome-file-types-properties.1.gz
Source7:      gnome-keybinding-properties.1.gz
Source8:      gnome-keyboard-properties.1.gz
Source9:      gnome-mouse-properties.1.gz
Source10:     gnome-network-preferences.1.gz
Source11:     gnome-font-properties.1.gz
Source12:     gnome-settings-daemon.1.gz
Source13:     gnome-sound-properties.1.gz
Source14:     gnome-ui-properties.1.gz
Source15:     gnome-desktop-prefs.1.gz
Source16:     gnome-theme-manager.1.gz
Source17:     gnome-window-properties.1.gz
Patch1:       control-center-01-menu-icon-reorder.diff
Patch2:       control-center-02-keybindings-close.diff
Patch3:	      control-center-03-help-links.diff
Patch4:       control-center-04-ctrl-alt-del.diff
Patch5:       control-center-05-solaris-forte-build.diff
Patch6:       control-center-06-g11n-schemas.diff
Patch7:       control-center-07-g11n-potfiles.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/control-center2
Autoreqprov:  on
Prereq:       /sbin/ldconfig
Prereq:       scrollkeeper

# Defines the standard prefix of the JDS common build environment
%define JDS_CBE_prefix /opt/jds

%define libgnomeui_version 2.4.0
%define esound_version 0.2.28
%define gnome_desktop_version 2.4.0
%define metacity_version 2.4.34
%define nautilus_version 2.4.0
%define fontilus_version 2.4.0
%define libxklavier_version 0.97
%define autoconf_jds_version 2.59
%define automake_jds_version 1.8.2
%define libtool_jds_version 1.5

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: esound-devel >= %{esound_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires: metacity >= %{metacity_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: libxklavier-devel >= %{libxklavier_version}
BuildRequires: autoconf-jds >= %{autoconf_jds_version}
BuildRequires: automake-jds >= %{automake_jds_version}
BuildRequires: libtool-jds >= %{libtool_jds_version}

Requires: libgnomeui >= %{libgnomeui_version}
Requires: esound >= %{esound_version}
Requires: gnome-desktop >= %{gnome_desktop_version}
Requires: nautilus >= %{nautilus_version}
Requires: libxklavier >= %{libxklavier_version}

Obsoletes:      fontilus < %{fontilus_version}
Provides:       fontilus = %{fontilus_version}

%description
This package contains the new control-center for the GNOME 2.0 desktop.

%prep
%setup -q
bzcat %SOURCE1 | tar xvf -
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1

%build
%ifos linux
export PATH=%{JDS_CBE_prefix}/bin:$PATH
export ACLOCAL_FLAGS="-I %{JDS_CBE_prefix}/share/aclocal -I %{_datadir}/aclocal"
%endif
LC_ALL=
LANG=
export LC_ALL LANG
libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros -I .
autoheader
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --libexecdir=%{_libexecdir} \
    --sysconfdir=%{_sysconfdir}
make 

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL       
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE7 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE8 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE9 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE10 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE11 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE12 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE13 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE14 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE15 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE16 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE17 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
scrollkeeper-update -q
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="apps_gnome_settings_daemon_default_editor.schemas apps_gnome_settings_daemon_screensaver.schemas desktop_gnome_font_rendering.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig
scrollkeeper-update -q

%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_prefix}/bin/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/pixmaps/*
%{_datadir}/idl/*.idl
%{_datadir}/control-center-2.0
%{_sysconfdir}/gconf/schemas/*.schemas
%{_datadir}/gnome-2.0/ui/*.xml
%{_datadir}/gnome/vfolders/*
%{_datadir}/gnome/cursor-fonts/*
%{_libdir}/*.so*
%{_libdir}/bonobo/servers/*
%{_libdir}/window-manager-settings/*.so*
%{_libexecdir}
%{_mandir}/man1/*

%changelog
* Tue Apr 6 2004 - [email protected]
- Bump to 2.6.0.3, and merge a bunch of the menu/title patches
  into one easy maintainable one. Patch the forte build issue
  on linux as well - we shouldn't special case this.

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to control-center-l10n-po-1.0.tar.bz2

* Thu Mar  4 2004 - [email protected]
- Added control-center-09-g11n-schemas.diff to localize schemas.in
- Added control-center-10-g11n-potfiles.diff to fix 4957377

* Thu Feb 26 2004 - [email protected]
- add libexecdir to pick up missing files

* Thu Feb 26 2004 - [email protected]
- Update Distro, l10n to 0.8

* Tue Feb 24 2004 - [email protected]
- define correct auto*-jds and libtool-jds versions

* Tue Feb 24 2004 - [email protected]
- set and export ACLOCAL_FLAGS on linux to
  pick up necessary JDS_CBE  aclocal macros.

* Fri Feb 20 2004 - [email protected]
- Added build dependencies on jds CBE auto* tools
  and set PATH to pick up their location on linux

* Wed Feb 18 2004 - [email protected]
- Bump to 2.5.3

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.0

* Fri Oct 31 2003 - [email protected]
- Remove the Sun Support keywords since
  we're moving away from the Extras menu.

* Tue Oct 21 2003 - [email protected]
- Add nautilus dependancy

* Mon Oct 19 2003 - [email protected]
- New tarball, bump version, reset release

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Tue Aug 05 2003 - [email protected]
- Close keybindings capplet on escape

* Tue Aug 05 2003 - [email protected]
- Add some metacity docs.

* Sat Aug 02 2003 - [email protected]
- Now we can theme X cursors

* Sat Aug 02 2003 - [email protected]
- Don't install gnomecc.desktop

* Fri Aug 01 2003 - [email protected]
- Add menu categorization cluepackets. Or something.

* Thu Jul 24 2003 - [email protected]
- Hide the password entry

* Tue Jul 22 2003 - [email protected]
- Change the window titles

* Mon Jul 21 2003 - [email protected]
- Reorder desktop preferences menu

* Thu Jul 17 2003 - [email protected]
- gnome-keybindings-properties uses the panel keys which are essential
  obsolete in the current release of GNOME. So replace these keys
  with the appropriate one that are appropriate in metacity.

* Thu Jul 17 2003 - [email protected]
- s/Files types and programs/File Associations

* Thu Jul 17 2003 - [email protected]
- Make sure the window icon lookup uses icon themes

* Tue Jul 15 2003 - [email protected]
- Backported the option to open the fonts folder from the fonts control panel.

* Wed Jul 09 2003 - [email protected]
- Added gnome-keyboard-layout to control centre.

* Fri Jul 03 2003 - [email protected]
- Add correct location for new sound icon and 
  add a theme icon.

* Fri Jul 03 2003 - [email protected]
- Install the .directory things

* Mon Jun 30 2003 - [email protected]
- add display properties capplet

* Fri Jun 27 2003 - [email protected]
- bump the version on the control center tarball

* Wed Jun 25 2003 - [email protected]
- add control-center-01-theme-failsafe.diff

* Wed May 14 2003 - [email protected]
- initial release