SUNWlibgc.spec
author halton
Thu, 27 Mar 2008 06:17:35 +0000
changeset 11922 da6b0e630b7d
parent 11773 b0c56dfc4139
child 12410 72cd6319f51f
permissions -rw-r--r--
2008-03-27 Halton Huo <[email protected]> * SUNWdesktop-search-libs.spec: Add copyright file * SUNWdesktop-search.spec: Add copyright file * SUNWgnome-remote-desktop.spec: Add copyright file * SUNWlibgc.spec: Add copyright file * SUNWlibgmime.spec: Add copyright file * SUNWprint-monitor.spec: Add copyright file * copyright/SUNWdesktop-search-libs.copyright: (new) UNWdesktop-search-libs copyright file * copyright/SUNWdesktop-search.copyright: (new) SUNWdesktop-search copyright file * copyright/SUNWgnome-remote-desktop.copyright: (new) SUNWgnome-remote-desktop copyright file * copyright/SUNWlibgc.copyright: (new) SUNWlibgc copyright file * copyright/SUNWlibgmime.copyright: (new) SUNWlibgmime copyright file * copyright/SUNWprint-monitor.copyright: (new) SUNWprint-monitor copyright file

#
# spec file for package SUNWlibgc
#
# includes module(s): libgc
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: halton
#
%include Solaris.inc

%use libgc = libgc.spec

Name:                    SUNWlibgc
Summary:                 Boehm-Demers-Weiser garbage collector for C/C++
Version:                 %{libgc.version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWlibms

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%prep
rm -rf %name-%version
mkdir %name-%version
%libgc.prep -d %name-%version

%build
export CFLAGS="%optflags"
export LDFLAGS="%{_ldflags}"

%libgc.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%libgc.install -d %name-%version

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gc

%changelog
* Thu Mar 27 2008 - [email protected]
- Add copyright file
* Sun Mar 02 2008 - [email protected]
- Correct package version number.
* Thu Jan 03 2008 - [email protected]
- Use base spec libgc.spec
* Mon Oct 15 2007 - [email protected]
- Bump to 7.0
- s/gc%{version}/gc-%{version}/g
- Add *.pc to %files devel
* Thu Jul  6 2006 - [email protected]
- rename to SFEhp-gc
- delete -share subpkg
- update file attributes
- delete unnecessary env variables
* Mon Jan 30 2006 - [email protected]
- Initial version