specs/SUNWPython26-extra.spec
author Jon Tibble <meths@btinternet.com>
Sat, 06 Oct 2012 16:11:50 +0100
branchs11express-2010-11
changeset 22109 db10202d5f6d
parent 20065 8cf85d0a1d82
child 20169 269b1e9ef64e
permissions -rw-r--r--
Added tag oi_151a_prestable7 for changeset 25dee50cecca

#
# spec file for package SUNWPython26-extra
#
# includes module(s): Pyrex, numpy
#
# Copyright 2009 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner laca
#
%include Solaris.inc
%define pythonver 2.6
%use pyrex = Pyrex.spec
%use numpy = numpy.spec

Name:                    SUNWPython26-extra
IPS_package_name:        library/python-2/python-extra-26
Meta(info.classification): %{classification_prefix}:Development/Python
Summary:                 Supplemental Python libraries and utilities
Version:                 2.6.1
License:                 Apache v2.0, NumPy
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWPython26
Requires: SUNWlexpt
BuildRequires: SUNWPython26-devel
BuildRequires: SUNWpython26-setuptools

%prep
rm -rf %name-%version
mkdir %name-%version
%pyrex.prep -d %name-%version
%numpy.prep -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
export PYTHON=/usr/bin/python2.6
%pyrex.install -d %name-%version
%numpy.install -d %name-%version

mv $RPM_BUILD_ROOT%{_bindir}/pyrexc $RPM_BUILD_ROOT%{_bindir}/pyrexc2.6

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*


%changelog
* Mon Feb  2 2009 - [email protected]
- create based on SUNWPython25-extra.spec
* Mon Nov 24 2008 - [email protected]
- created, based on SUNWPython-extra.spec
* Thu Oct 25 2007 - [email protected]
- Add numpy to add numerical processing extensions to Python.
* Thu Jul 27 2006 - [email protected]
- add elementtree
* Thu Oct 27 2005 - [email protected]
- add PyXML
- move pyspi to SUNWgnome-python-libs
- change permissions to root:bin
* Thu Oct 20 2005 - [email protected]
- Use %{default_pkg_version} instead of python version.
* Wed Oct 19 2005 - [email protected]
- Initial version.