libsoup.spec
author dermotm
Mon, 19 Apr 2004 17:29:14 +0000
changeset 2493 db8d8f0373b1
parent 2484 05defe239586
child 2494 6b1189c3cc84
permissions -rw-r--r--
evo/moz - update to build 08b

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build08b
%{?tarball_suffix:%define t_suffix %tarball_suffix}

Name:     	libsoup
Version: 	1.99.23
Release:	324
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	LGPL/GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
#Patch0:         libsoup.patch

%define libxml2_devel_version 2.4.23
%define glib2_version 2.0

BuildRequires:	glibc-devel
BuildRequires:	libtool
BuildRequires:	glib2-devel
BuildRequires:	libxml2-devel >= %{libxml2_devel_version}
BuildRequires:	popt
BuildRequires:	zlib-devel
BuildRequires:	gnutls-devel	
Summary:	Simple Object Access Protocol implementation
Group:		System Environment/Libraries
Requires:	glib2 >= %{glib2_version}
Requires:	popt
Requires:	libxml2

%description
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

%files
%defattr(-, root, root)
%doc COPYING ChangeLog AUTHORS INSTALL NEWS TODO README
%{_libdir}/lib*.so.*


%post
ldconfig

%package -n libsoup-devel
Summary:	Simple Object Access Protocol implementation
Group:		Development/Libraries
Requires:	%{name} = %{version}-%{release}
Requires:	glib2-devel
Requires:	libxml2-devel

%description -n libsoup-devel
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

This package allows you to develop applications that use the Soup library.

%files -n libsoup-devel
%defattr(-, root, root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*


# $RPM_COMMAND is an environment variable used by the SUN build
# system to control the build process with finer granularity than RPM
# normally allows.  This specfile will function as expected by RPM if
# $RPM_COMMAND is unset.  If you are not the SUN build system,
# feel free to ignore it.

%prep
case "${RPM_COMMAND:-all}" in
dist)
%setup  -q -D -n %{name}-%{version}
    ;;
all)
%setup  -q -n %{name}-%{version}
    ;;
esac
#case "${RPM_COMMAND:-all}" in
#dist|all)
#%patch -p1 -P 0
#    ;;
#esac

%build
MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND DESTDIR ARCH
case "$RPM_COMMAND" in
prepare|all)
    libtoolize
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    autoheader
    automake -a -f -c
    autoconf
    ./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --mandir=%{_mandir} --infodir=%{_datadir}/info --localstatedir=/var --enable-more-warnings=no --enable-gtk-doc=no  --with-gnutls-libs=%{_libdir} --with-gnutls-includes=%{_includedir}
    ;;
esac
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE}
    ;;
esac

%install
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
# export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
    ${MAKE} install prefix=${DESTDIR}%{_prefix} sysconfdir=${DESTDIR}%{_sysconfdir} mandir=${DESTDIR}%{_mandir} infodir=${DESTDIR}%{_datadir}/info localstatedir=${DESTDIR}/var
    ;;
esac

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac


%changelog