gnome-system-tools.spec
author laca
Wed, 15 Nov 2006 22:18:11 +0000
changeset 8564 df62c23d2955
parent 8394 bcd58bae020d
child 8581 2a42a769ce54
permissions -rw-r--r--
assign owners to spec files

#
# spec file for package gnome-system-tools
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#
Name:		gnome-system-tools
License:	GPL
Group:		System/GUI/GNOME
# WARNING: Do NOT bump version as other dependencies (e.g DBUS) need work first.
Version:	2.14.0
Release:	1
Distribution:	Java Desktop System
Vendor:		Sun Microsystems, Inc.
Summary:	GNOME System Tools
Source:		http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.14/%{name}-%{version}.tar.bz2
Patch1:		gnome-system-tools-01-config.diff
Patch2:		gnome-system-tools-02-forkpty.diff
Patch3:		gnome-system-tools-03-network.diff
Patch4:		gnome-system-tools-04-tz.diff
Patch5:		gnome-system-tools-05-shares.diff
Patch6:		gnome-system-tools-06-time.diff
Patch7:		gnome-system-tools-07-users.diff
Patch8:		gnome-system-tools-08-services.diff
URL:		http://www.gnome.org
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:		%{_defaultdocdir}/%{name}
Autoreqprov:	on
Prereq:         GConf

%define libgnomeui_version 2.9.0
%define GConf_version 2.2.0
%define system_tools_backends_version 1.2.0
%define nautilus_version 2.9.3

Requires:	libgnomeui >= %{libgnomeui_version}
Requires:	GConf >= %{GConf_version}
Requires:	system-tools-backends >= %{system_tools_backends_version}
Requires:	nautilus >= %{nautilus_version}
BuildRequires:  libgnomeui-devel >= %{libgnomeui_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:	system-tools-backends >= %{system_tools_backends_version}
BuildRequires:	nautilus-devel >= %{nautilus_version}
BuildRequires:  intltool

%description
These tools are intended to simplify the tasks of configuring a Unix system
for workstations. They are not intended for configuring Unix servers.

Configuring different Unix systems is different; every Unix system has
different ways of being administrated. The GNOME System Tools aspire to
unify these systems.

Each one of the GNOME System Tools is split in two parts: a backend (which
is typically written in Perl) and a user interface frontend (which is
typically written in C or Python).

The backends are written in a way that should allow us to quickly adapt
them to various different flavors of Unix; the backend probes your system
and parses the existing system files. When the user has finished editing
the system settings, the configuration is written back as patches to the
system files.

This means that the GNOME System Tools use whatever configuration files are
available on your system, and you can still edit those files by hand or
with other configuration tools without conflicts or data loss.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

glib-gettextize -f
aclocal $ACLOCAL_FLAGS
libtoolize --force
autoheader
autoconf

%ifos solaris
CFLAGS="-D NOPTY -D USE_AUTHEN_PAM $RPM_OPT_FLAGS" \
%else
CFLAGS="$RPM_OPT_FLAGS" \
%endif

  ./configure \
	--prefix=%{_prefix} 		  \
	--sysconfdir=%{_sysconfdir}       \
	--localstatedir=%{_localstatedir} \
	--mandir=%{_mandir}	          \
	--disable-scrollkeeper
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.la
rm $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.a
rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gnome-system-tools.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%defattr (-, root, root)
%{_bindir}/*
%{_libdir}/nautilus/extensions-1.0/libnautilus-gst-shares.so
%{_libdir}/pkgconfig/
%{_datadir}/applications/
%{_datadir}/gnome-system-tools/
%{_datadir}/gnome/help/
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/
%{_sysconfdir}/gconf/schemas/*

%changelog
* Sat Oct 21 2006 - [email protected]
- Run autoconf since we're patching configure.ac to look for gksu.

* Mon Apr 10 2006 - [email protected]
- Add define USE_AUTHEN_PAM for Solaris

* Fri Mar 24 2006 - [email protected]
- Add patch gnome-system-tools-07-users.diff.

* Thu Mar 16 2006 - [email protected]
- Move patches here from Solaris package spec file.

* Tue Mar 14 2006 - [email protected]
- Bump to 2.14.0.

* Thu Feb  2 2006 - [email protected]
- Bump to 2.13.2.

* Fri Jan 20 2006 - [email protected]
- Bump to 2.13.1.

* Tue Sep 27 2005 - [email protected]
- Bump to 1.3.92.

* Mon Aug 15 2005 - [email protected]
- Bump to 1.3.2.

* Tue May 24 2005 - [email protected]
- Initial spec