gnome-python.spec
author dc144907
Tue, 22 Aug 2006 16:03:38 +0000
changeset 7950 eb1dcec5e949
parent 7760 f423c5a9415b
child 8065 ee7f9ab71fae
permissions -rw-r--r--
2006-08-22 Damien Carbery <[email protected]> * nautilus.spec: Bump to 2.15.92. * gnome-themes.spec: Bump to 2.15.92. * eog.spec: Bump to 2.15.92. * gnome-speech.spec: Bump to 0.4.4. * pango.spec: Bump to 1.14.1. * gnome-system-monitor.spec: Bump to 2.15.92. * pygobject.spec: Bump to 2.11.3. * gdm.spec: Bump to 2.15.10. * file-roller.spec: Bump to 2.15.92 * patches/file-roller-02-rename-contents.diff: Rework. * patches/file-roller-03-menu-entry.diff: Rework. * atk.spec: Bump to 2.15.92 * at-spi.spec: Bump to 2.15.92 * gail.spec: Bump to 2.15.92 * gedit.spec: Bump to 2.15.92 * gnome-icon-theme.spec: Bump to 2.15.92 * gnome-backgrounds.spec: Bump to 2.15.92 * dasher.spec: Bump to 2.15.92 * gnome-python.spec: Bump to 2.15.92 * metacity.spec: Bump to 2.15.34. * gtk2-engines.spec: Bump to 2.7.8. * libwnck.spec: Bump to 2.15.92. * gnome-desktop.spec: Bump to 2.15.92. * gnome-session.spec: Bump to 2.15.92. * patches/gnome-session-10-fixcrash.diff: Removed, upstream. * patches/gnome-session-10-wait-for-postrun.diff: Rename from 11. * patches/gnome-session-11-trusted-extensions.diff: Rename from 12. * gnome-panel.spec: Bump to 2.15.92. * patches/gnome-panel-03-fish-applet.diff: Rework. * patches/gnome-panel-06-notificationarea-tooltip.diff: Rework. * patches/gnome-panel-11-clock-timezone.diff: Rework. * gnome-screensaver.spec: Bump to 2.15.7. * nautilus-cd-burner.spec: Bump to 2.15.7. * bug-buddy.spec: Bump to 2.15.92. * gnome-keyring-manager.spec: Bump to 2.15.92.

#
# spec file for package gnome-python
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-python
License:		LGPL	
Group:			System/Library
Version:		2.15.91
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Python bindings for various GNOME libraries
Source:			http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.15/gnome-python-%{version}.tar.bz2
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		off

%define libglade_version           2.4.0
%define python_version             2.4
%define pygtk2_version             2.4.0
%define pyorbit_version            2.0.1
%define libgnomeui_version         2.0.0
%define gconf_version              1.2.0
%define nautilus_version           2.0.0
%define gnome_panel_version        2.0.0
%define gtkhtml_version            2.3.1
%define libgnomeprintui_version    2.2.0

Requires: python >= %{python_version}
Requires: pygtk2 >= %{pygtk2_version}
Requires: pyorbit >= %{pyorbit_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libglade >= %{libglade_version}
Requires: GConf >= %{gconf_version}
Requires: nautilus >= %{nautilus_version}
Requires: gnome-panel >= %{gnome_panel_version}
Requires: gtkhtml >= %{gtkhtml_version}
Requires: libgnomeprintui >= %{libgnomeprintui_version}

BuildRequires: python >= %{python_version}
BuildRequires: pygtk2-devel >= %{pygtk2_version}
BuildRequires: pyorbit-devel >= %{pyorbit_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: GConf-devel >= %{gconf_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
BuildRequires: gtkhtml-devel >= %{gtkhtml_version}
BuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}

%description
GNOME-Python provides the Python language bindings for the GNOME libraries.

%package devel
Summary: Files needed to build applications using the Python bindings for GNOME libraries
Group: Development/Languages
Requires: %{name} = %{version}

%description devel
This package contains files required to build Python applications that need 
to interope rate with the various GNOME libraries

%prep
%setup -q -n gnome-python-%{version}

%build
CFLAGS="$RPM_OPT_FLAGS"				\
./configure 	--prefix=%{_prefix}		\
	    	--sysconfdir=%{_sysconfdir}
make \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
make install DESTDIR=$RPM_BUILD_ROOT \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages/gtk-2.0
%{_libdir}/gnome-vfs-*/modules/lib*.so

%doc AUTHORS NEWS README ChangeLog
%doc examples

%files devel
%defattr(644, root, root)
%{_libdir}/pkgconfig/*
%{_datadir}/pygtk
%{_includedir}/*

%changelog -n gnome-python
* Tue Aug 22 2006 - [email protected]
- Bump to 2.15.91.

* Wed Jul 26 2006 - [email protected]
- Bump to 2.15.90.

* Fri Jul 21 2006 - [email protected]
- Bump to 2.15.4.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.12.4.

* Tue Jan 03 2006 - [email protected]
- Bump to 2.12.3.

* Tue Dec 20 2005 - [email protected]
- Bump to 2.12.2

* Thu Oct 27 2005 - [email protected]
- move from site-packages to vendor-packages
- include the .pyc files

* Fri Aug 26 2005 - [email protected]
- fix dependencies, fix %files

* Fri Aug 12 2005 - [email protected]
- Initial Sun release