SUNWgnome-help-viewer.spec
author henryz
Wed, 09 Apr 2008 07:35:21 +0000
changeset 12065 ec40d145a28b
parent 11958 9a5520e3cc7a
child 12183 2794b17c5b94
permissions -rw-r--r--
+2008-04-09 Henry Zhang <[email protected]> + + * patches/virt-manager-04-temporary-patch.diff: + Change the patch to fix AllY bug, 6686007 +

#
# spec file for package SUNWgnome-help-viewer
#
# includes module(s): yelp
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc

%use yelp = yelp.spec

Name:                    SUNWgnome-help-viewer
Summary:                 GNOME help system
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires:	SUNWgnome-help-viewer
Requires:	SUNWgnome-libs
Requires:       SUNWgnome-vfs
Requires:       SUNWgnome-component
Requires:       SUNWgnome-base-libs
Requires:       SUNWgnome-config
Requires:       SUNWlxml
Requires:       SUNWlxsl
Requires:  	SUNWfirefox
Requires:       SUNWbzip
Requires:       SUNWgnome-print
Requires:       SUNWlibC
Requires:       SUNWlibpopt
Requires:       SUNWzlib
Requires:       SUNWpostrun
BuildRequires:  SUNWgnome-print-devel
BuildRequires:  SUNWlibpopt-devel
BuildRequires:  SUNWfirefox-devel
BuildRequires:  SUNWgnome-print-devel
BuildRequires:  SUNWgnome-vfs-devel
BuildRequires:  SUNWgnome-component-devel
BuildRequires:  SUNWgnome-libs-devel
BuildRequires:  SUNWgnome-base-libs-devel
BuildRequires:  SUNWgnome-config-devel
BuildRequires:  SUNWgnome-doc-utils
BuildRequires:  SUNWlxml
BuildRequires:  SUNWlxsl

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%yelp.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -


%build
export CFLAGS="%optflags -I/usr/sfw/include -I/usr/sfw/include/freetype2 -I%{_includedir}/mps -DANSICPP -DI_KNOW_RARIAN_0_8_IS_UNSTABLE"
export RPM_OPT_FLAGS="$CFLAGS"
export CXXFLAGS="%cxx_optflags -I%{_includedir}/mps"
export PKG_CONFIG_PATH=%{_pkg_config_path}:/usr/sfw/lib/pkgconfig
#FIXME: freetype2.m4?
export ACLOCAL_FLAGS="-I ./m4 -I /usr/sfw/share/aclocal"
%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif
export LDFLAGS="%_ldflags"

%yelp.build -d %name-%version

%install
%yelp.install -d %name-%version
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post root
%include gconf-install.script

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'retval=0';
  echo 'for schemas in yelp; do' ;
  echo '  $PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $SDIR/$schemas.schemas || retval=1';
  echo 'done';
  echo 'exit $retval'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%attr (-, root, other) %{_datadir}/icons
%{_datadir}/yelp
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/yelp.schemas

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Thu Jan 24 2008 - [email protected]
- Fix up gconf install
* Wed Nov 28 2008 - [email protected]
- Add -DI_KNOW_RARIAN_0_8_IS_UNSTABLE to CFLAGS as required by rarian-info.h.
* Thu Oct 11 2007 - [email protected]
- Remove install dependency on SUNWgnome-doc-utils and change the build
  dependency from SUNWgnome-doc-utils-devel to SUNWgnome-doc-utils.
* Fri Sep 28 2007 - [email protected]
- delete SUNWxwrtl dep
- add -norunpath flag for CXX and fix LDFLAGS
* Fri Aug 17 2007 - [email protected]
- Move rarian to SUNWgnome-libs.spec, replacing scrollkeeper. Remove devel
  package and other rarian related changes.
* Wed Aug 01 2007 - [email protected]
- Add rarian module as required by yelp 2.19.1.
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Wed Jul 26 2006 - [email protected]
- Bump to 2.15.5, update %files, bonobo support has been removed.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Sat May 13 2006 - [email protected]
- Remove /usr/lib/jds-private from LDFLAGS
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Jan 05 2006 - [email protected]
- Complete the Build/Requires lists.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Fri Sep 30 2005 - [email protected]
- Add icons dir to %files; remove /etc dir before packaging.
* Thu Jul 21 2005 - [email protected]
- Add SUNWmozilla dependency as configure breaking without mozilla.
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Wed Aug 18 2004 - [email protected]
- Change manpage perms for Solaris integration.
* Fri Jul 09 2004 - [email protected]
- Return -R to LDFLAGS. I had incorrectly implemented the ARC decision.
* Thu Jul 08 2004 - [email protected]
- Remove -R from LDFLAGS because ARC said to use -norunpath.
* Fri Jul 02 2004 - [email protected]
- Add /usr/lib/jds-private to LDFLAGS.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Fri May 14 2004 - [email protected]
- Added libxslt dependency
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Mon Mar 01 2004 - <[email protected]>
- define PERL5LIB.
- remove non-existant dirs from %files share
* Tue Feb 17 2004 - <[email protected]
- initial spec file created