SUNWgnome-panel.spec
author henryz
Wed, 09 Apr 2008 07:35:21 +0000
changeset 12065 ec40d145a28b
parent 12061 2f65e282509d
child 12076 9a011110c4fa
permissions -rw-r--r--
+2008-04-09 Henry Zhang <[email protected]> + + * patches/virt-manager-04-temporary-patch.diff: + Change the patch to fix AllY bug, 6686007 +

#
# spec file for package SUNWgnome-panel
#
# includes module(s): libwnck, libnotify, notification-daemon, libgweather,
#                     gnome-desktop, gnome-menus, gnome-panel
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc
%use lwnck = libwnck.spec
%use gdesktop = gnome-desktop.spec
%use gnome_menus = gnome-menus.spec
%use libgweather = libgweather.spec
%use gpanel = gnome-panel.spec
%use libnotify = libnotify.spec
%use notificationdaemon = notification-daemon.spec

Name:                    SUNWgnome-panel
Summary:                 GNOME panel and support libraries
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
Source1:                 %{name}-gnome-about.ksh
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-vfs-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-doc-utils
BuildRequires: SUNWlibpopt-devel
BuildRequires: SUNWpng-devel
BuildRequires: SUNWsolnm
BuildRequires: SUNWarc
BuildRequires: SUNWevolution-data-server-devel
BuildRequires: SUNWiso-codes-devel
BuildRequires: SUNWdbus-devel
BuildRequires: SUNWlxml-devel
BuildRequires: SUNWlxml-python
BuildRequires: SUNWlibrsvg-devel
Requires: SUNWgnome-panel-root
Requires: SUNWgnome-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-vfs
Requires: SUNWlxml
Requires: SUNWgnome-component
Requires: SUNWlibpopt
Requires: SUNWlibms
Requires: SUNWlibrsvg
Requires: SUNWpng
Requires: SUNWpostrun
Requires: SUNWevolution-data-server
Requires: SUNWiso-codes
Requires: SUNWdbus

%if %build_tjds
BuildRequires: SUNWtgnome-tsol-libs-devel
%endif
%if %option_without_fox
%ifarch i386
Requires: SUNWxorg-xkb
BuildRequires: SUNWxorg-xkb
%endif
%endif

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-libs-devel
Requires: SUNWgnome-panel
Requires: SUNWgnome-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-component
Requires: SUNWgnome-base-libs

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%lwnck.prep -d %name-%version
%libnotify.prep -d %name-%version
%notificationdaemon.prep -d %name-%version
%gdesktop.prep -d %name-%version
%gnome_menus.prep -d %name-%version
%libgweather.prep -d %name-%version
%gpanel.prep -d %name-%version
chmod -R u+w %{_builddir}/%name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
PKG_CONFIG_DISABLE_UNINSTALLED=
unset PKG_CONFIG_DISABLE_UNINSTALLED
export PKG_CONFIG_PATH="../gnome-desktop-%{gdesktop.version}/libgnome-desktop:../libwnck-%{lwnck.version}:../gnome-menus-%{gnome_menus.version}/libmenu:../libgweather-%{libgweather.version}/libgweather:../gnome-panel-%{gpanel.version}/libpanel-applet"
export CFLAGS="%optflags -I/usr/sfw/include -I/usr/openwin/share/include -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
export CPPFLAGS="-I/usr/sfw/include"
export LDFLAGS="%_ldflags -L/usr/sfw/lib -R/usr/sfw/lib -L/usr/openwin/sfw/lib -R/usr/openwin/sfw/lib -L/usr/openwin/lib -R/usr/openwin/lib"

%lwnck.build -d %name-%version

%libnotify.build -d %name-%version
%notificationdaemon.build -d %name-%version

export CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
%gdesktop.build -d %name-%version
%gnome_menus.build -d %name-%version
%libgweather.build -d %name-%version
%gpanel.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%lwnck.install -d %name-%version

%libnotify.install -d %name-%version
%notificationdaemon.install -d %name-%version
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.la" -exec rm -f {} ';'

%gdesktop.install -d %name-%version
%gnome_menus.install -d %name-%version
%libgweather.install -d %name-%version
rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/gweather.pc

%gpanel.install -d %name-%version

rm -r $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

chmod 0644 $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/C/*.xml

# Remove empty directories
rm -r $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1
rm -r $RPM_BUILD_ROOT%{_datadir}/dbus-1/system-services
rm -r $RPM_BUILD_ROOT%{_datadir}/PolicyKit

%if %option_with_sun_branding
# Change to allow for addition of a gnome-about wrapper script to allow
# one-time processing.
# Move binary to /usr/lib
mv $RPM_BUILD_ROOT/%{_bindir}/gnome-about $RPM_BUILD_ROOT/%{_libdir}/gnome-about
# Now place script in to bin dir.
install --mode=0755 %SOURCE1 $RPM_BUILD_ROOT/%{_bindir}/gnome-about
%endif

%if %build_l10n
%else
# REMOVE l10n FILES
#FIXME: really need to fix this stuff up
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-c]*/[a-z]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/[e-z]*/[a-z]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z]*.omf
rmdir $RPM_BUILD_ROOT%{_datadir}/omf/window-list
rmdir $RPM_BUILD_ROOT%{_datadir}/omf/workspace-switcher
rmdir $RPM_BUILD_ROOT%{_datadir}/omf/gnome-panel
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post root
%include gconf-install.script
( echo 'test -x /usr/bin/gconftool-2 || {';
  echo '  echo "ERROR: gconftool-2 not found"';
  echo '  exit 1';
  echo '}';
  echo 'umask 0022';
  echo "GCONF_CONFIG_SOURCE=xml:merged:%{_sysconfdir}/gconf/gconf.xml.defaults";
  echo 'export GCONF_CONFIG_SOURCE';
  echo "SDIR=%{_sysconfdir}/gconf/schemas";
  echo 'retval=0';
  echo '/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries || retval=1';
  echo '/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --load %{_sysconfdir}/gconf/schemas/panel-default-setup.entries /apps/panel/profiles/default|| retval=1';
  echo 'exit $retval'
) | $BASEDIR/var/lib/postrun/postrun -c JDS_wait

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'retval=0';
  echo 'for schemas in clock panel-compatibility panel-general panel-global \';
  echo '               panel-object panel-toplevel window-list gweather \';
  echo '               workspace-switcher notification-daemon; do' ;
  echo '  $PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $SDIR/$schemas.schemas > /dev/null || retval=1';
  echo 'done';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --unload $SDIR/panel-default-setup.entries || retval=1';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2  --direct --config-source=$GCONF_CONFIG_SOURCE --unload $SDIR/panel-default-setup.entries /apps/panel/profiles/default || retval=1';
  echo 'exit $retval'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gnome-about
%{_bindir}/gnome-panel
%{_bindir}/gnome-desktop-item-edit
%{_bindir}/gnome-cleanup
%{_bindir}/gmenu-simple-editor
%{_bindir}/notify-send
%{_bindir}/wnckprop
%dir %attr (0755, root, bin) %{_libdir}
%if %option_with_sun_branding
%{_libdir}/gnome-about
%endif
%{_libdir}/lib*.so*
%{_libdir}/python*
%{_libdir}/bonobo/servers/*.server
%{_libdir}/notification-daemon
%dir %attr (0755, root, bin) %{_libdir}/notification-daemon-1.0
%dir %attr (0755, root, bin) %{_libdir}/notification-daemon-1.0/engines
%{_libdir}/notification-daemon-1.0/engines/*.so*
%{_libexecdir}/*-applet
%dir %attr(0755, root, sys) %{_datadir}
%{_datadir}/gnome-about
%{_datadir}/gnome-menus
%{_datadir}/desktop-directories
%{_datadir}/omf/*/*-C.omf
%{_datadir}/gnome-panel/glade/clock.glade
%{_datadir}/gnome-panel/glade/timezone.glade
%{_datadir}/gnome-panel/glade/workspace-switcher.glade
%{_datadir}/gnome-panel/glade/window-list.glade
%{_datadir}/gnome-panel/glade/panel-properties-dialog.glade
%{_datadir}/gnome-panel/glade/panel-run-dialog.glade
%{_datadir}/gnome-panel/pixmaps
%{_datadir}/gnome-panelrc
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/*/C
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%attr (-, root, other) %{_datadir}/icons
%{_datadir}/gnome-2.0/ui/*.xml
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%{_datadir}/libgweather
%dir %attr (0755, root, bin) %{_datadir}/dbus-1
%dir %attr (0755, root, bin) %{_datadir}/dbus-1/services
%{_datadir}/dbus-1/services/org.freedesktop.Notifications.service
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*
%dir %attr(0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*
%dir %attr(0755, root, bin) %{_mandir}/man5
%{_mandir}/man5/*

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/clock.schemas
%{_sysconfdir}/gconf/schemas/gweather.schemas
%{_sysconfdir}/gconf/schemas/panel-compatibility.schemas
%{_sysconfdir}/gconf/schemas/panel-general.schemas
%{_sysconfdir}/gconf/schemas/panel-global.schemas
%{_sysconfdir}/gconf/schemas/panel-object.schemas
%{_sysconfdir}/gconf/schemas/panel-toplevel.schemas
%{_sysconfdir}/gconf/schemas/window-list.schemas
%{_sysconfdir}/gconf/schemas/workspace-switcher.schemas
%{_sysconfdir}/gconf/schemas/notification-daemon.schemas
%{_sysconfdir}/gconf/schemas/panel-default-setup.entries
%{_sysconfdir}/xdg

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/panel-test-applets
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr(0755, root, sys) %{_datadir}
%{_datadir}/idl
%{_datadir}/gtk-doc
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome-panel/glade/panel-test-applets.glade

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/gnome
%attr (-, root, other) %{_datadir}/locale
%{_datadir}/gnome/help/[a-c]*/[a-z]*
%{_datadir}/gnome/help/[e-z]*/[a-z]*
%{_datadir}/omf/*/*-[a-z][a-z].omf
%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf
%endif

%changelog
* Tue Apr 8 2008 - [email protected]
- Add libgweather include back in as required by SUNWgnome-applets
* Mon Apr 7 2008 - [email protected]
- Remove libgweather include and pc file in %install section
* Wed Feb 13 2008 - [email protected]
- Update %files, removing %{_bindir}/gnome-menu-spec-test.
* Thu Jan 17 2008 - [email protected]
- Add BuildRequires SUNWlibrsvg-devel because librsvg is required by
  gnome-panel 2.21.5. Remove some empty dirs.
* Thu Nov 15 2007 - [email protected]
- Add BuildRequires SUNWlxml-python for building documentation.
* Fri Oct 19 2007 - [email protected]
- only install the gnome-about wrapper script if sun branding is requested
* Thu Oct 11 2007 - [email protected]
- Remove install dependency on SUNWgnome-doc-utils and change the build
  dependency from SUNWgnome-doc-utils-devel to SUNWgnome-doc-utils.
* Fri Sep 28 2007 - [email protected]
- delete Nevada X deps; make xorg-xkb dep dependent upon nevada X build
- delete some unneeded env vars
* Tue Jul 10 2007 - [email protected]
- Add %{_bindir}/wnckprop and update dir for timezone.glade in %files.
* Tue Jun 26 2007 - [email protected]
- gnome-panel-07-restrict-app-launching.diff changed. Fixes 6565785.
* Tue Jun 12 2007 - [email protected]
- re-include timezone glade file
* Tue May 15 2007 - [email protected]
- Some files now installed to %{_datadir}/gnome-panel instead of
  %{_datadir}/gnome/panel.
* Tue Apr 24 2007 - [email protected]
- s/0755/-/ in defattr so that files are not made all executable
* Wed Feb 14 2006 - [email protected]
- Delete en_GB files in %install.
* Sun Jan 28 2007 - [email protected]
- Add /usr/openwin/lib to library search path, needed for libXau on s10.
* Fri Jan 12 2006 - [email protected]
- No longer remove %{datadir}/omf/gnome-feedback since this was removed
  from gnome-desktop.
* Thu Dec 07 2006 - [email protected]
- Create a wrapper script around gnome-about to handle Solaris Developer Guide
  launching.
* Tue Nov 21 2006 - [email protected]
- Remove man3 dir from -devel package. Fixes 6495907.
* Sat Nov 04 2006 - [email protected]
- Undo removal of man5 dir. A manpage is installed there.
* Fri Nov 03 2006 - [email protected]
- Remove man5 dir as nothing is installed there now. Add man3 dir as updated 
  manpage tarball installs 2 files there.
* Tue Sep 05 2006 - [email protected]
- Remove libxklavier from the build.
* Mon Sep 04 2006 - [email protected]
- Fix comments.  Also remove -g from CFLAGS.  Not good to have on by default
  for performance.
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Mon Aug 21 2006 - [email protected]
- Fix l10n package - C locale omf file was in base and l10n package.
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Mon Jun 26 2006 - [email protected]
- remove the dependency from thunderbird since this dependency doesn't 
  exist any more
* Fri Jun 23 2006 - [email protected]
- Removed gkb_xmmap.1 and gnome-panel-preferences.1 manpages
* Sun Jun 11 2006 - laca.com
* Thu Jun 22 2006 - [email protected]
- Add Build/Requires SUNWevolution-data-server/-devel after check-deps.pl run.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon May 01 2006 - [email protected]
- Change build dependency from SUNWthunderbird-devel to SUNWthunderbird as the
  devel package has been removed. 
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Feb 14 2006 - [email protected]
- Remove scrollkeeper files before packaging.
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Wed Nov 09 2005 - [email protected]
- Add Build/Requires SUNWthunderbird, for libnss3.so dependency.
* Thu Oct 27 2005 - [email protected]
- Remove some empty dirs when not building l10n packages.
* Mon Sep 12 2005 - [email protected]
- Remove unpackaged files or add to %files
* Tue Aug 30 2005 - [email protected]
- Add BuildRequires SUNWgnome-doc-utils-devel as gnome-desktop uses
  gnome-doc-prepare.
  Correct packaging list (gif->png) and remove some docs lines.
* Wed Jul 13 2005 - [email protected]
- Split SUNWgnome-panel to two spec files, SUNWgnome-panel and
  SUNWgnome-applets.spec
* Wed May 25 2005 - [email protected]
- Finally finished packaging this for Solaris.
* Tue May 24 2005 - [email protected]
- More packaging fixes.  Not yet completely right.
* Thu May 20 2005 - [email protected]
- Packaging fixes.  Not yet completely right, but better.
* Fri May 13 2005 - [email protected]
- Removed now from panel since it doesn't build right.  It has
  AC_CONFIG_AUX_DIR set to config, which causes intltoolize to fail.
* Fri May 13 2005 - [email protected]
- Fix PKG_CONFIG_PATH for 2.10 and add new gnome-menus.
* Fri Apr 08 2005 - [email protected]
- Add hicolor locations.
* Fri Jan 28 2005 - [email protected]
- #6222336 : Remove gweather from yelp toc
* Wed Nov 24 2004 - [email protected]
- Add English help files under l10n dir to fix 6197769(P1 STP)
* Tue Nov 16 2004 - [email protected]
- move section 5 man page to share from devel-share
* Tue Nov 02 2004 - [email protected]
- Added BuildConflicts: SUNWgnome-media
* Fri Oct 29 2004 - [email protected]
- pick the desktop files from datadir/applications
* Tue Oct 19 2004 - [email protected]
- remove xorg-xkb dependency on sparc as it's only available on x86
* Fri Oct  8 2004 - [email protected]
- Comment out %{_bindir}/now to match now.spec.
* Mon Oct 04 2004 - [email protected]
- Remove drivemount help files #5108690
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Fri Oct  1 2004 - [email protected]
- Remove references to fish applet to match gnome-panel.spec change.
* Thu Sep 30 2004 - [email protected]
- Added code to install "gswitchit" help documents.
  Fixes bug #5076490.
* Tue Sep 21 2004 - [email protected]
- Added code to install "now" help documents.
  Fixes bug #5101703.
* Sun Sep 13 2004 - [email protected]
- Move manpages from SUNWgnome-utility-applets to 
  SUNWgnome-utility-applets-share.
* Thu Sep 09 2004 - [email protected]
- Added gkb_xmmap.1, gnome-keyboard-layout.1, gswitchit-plugins-capplet.1
  manpages
* Mon Sep 06 2004 - [email protected]
- Bug 5083735 : Uncommented javahelp/gnome-netstatus from %files section
* Mon Aug 30 2004 - [email protected]
- Bug 5091588 : sman3/4/5 files should be in a separate devel package
* Mon Aug 23 2004 - [email protected]
- Bug 5090965 : Removed duplicate entries
* Wed Aug 18 2004 - [email protected]
- Changed xml perms to 0644 for Solaris integration.
- Changed manpage perms for Solaris integration.
* Mon Aug 16 2004 - [email protected]
- Changed SOURCE7 mode to 0755 for Solaris integration.
* Tue Aug 10 2004 - [email protected]
- Remove GNOME_DriveMountApplet.server to remove applet's panel menu entry.
* Tue Jul 27 2004 - [email protected]
- Remove drivemount on Solaris. Part fix for #5043894
* Fri Jul 23 2004 - [email protected]
- Remove GNOME_WirelessApplet.xml because a gnome-panel.spec patch remove it.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Fri Jun 25 2004 - [email protected]
- Updated for mini commander applet.
* Thu Jun 24 2004 - [email protected]
- Associate default macros for mini commander applet.
* Thu May 27 2004 - [email protected]
- added gnome-cleanup man page.  Also made SUNWgnome-media a dependency
  since it is needed for the mixer applet.
* Thu May 27 2004 - [email protected]
- added l10n subpkg
* Fri May 28 2004 - <[email protected]>
- added gnome-cleanup to %files
* Mon May 24 2004 - <[email protected]>
- Only Sun banner should show up in gnome-about.
* Fri May 21 2004 - <[email protected]>
- Remove wireless applet from the Solaris builds.
* Sun May 02 2004 - <[email protected]>
- don't redefine __STDC_VERSION__ on S9, as it breaks the build.
* Fri Apr 30 2004 - <[email protected]>
- get the panel-default-setup.entries to be installed in
  $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
* Wed Apr 07 2004 - <[email protected]>
- update quick-lounge-applet files
* Fri Mar 26 2004 - <[email protected]>
- fixed libexecdir in %files
- update gnome-netstatus icon locations
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Wed Mar 10 2004 - <[email protected]>
- remove duplicate entries from %files
* Wed Mar 03 2004 - <[email protected]>
- merge in gnome-netstatus applet
* Tue Mar 02 2004 - <[email protected]>
- add %libical.install
- add libical*.so*
* Mon Feb 23 2004 - <[email protected]>
- install gconf schemas at end of install stage.
- define mappings for all the installed schemas