specs/SUNWgir-repository.spec
author yippi
Thu, 05 Aug 2010 11:47:22 +0000
changeset 19973 f05dadadf325
parent 17937 664c0536875a
child 19985 62e3256a8655
permissions -rw-r--r--
Fix copyright lines.

#
# spec file for package SUNWgir-repository
#
# includes module(s): gir-repository
#
# Copyright (c) 2009, 2010, Oracle and/or its affiliates. All rights reserved.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
#
%include Solaris.inc

%define pythonver 2.6
%use gir = gir-repository.spec

Name:               SUNWgir-repository
Summary:            GIR Repository
Version:            %{gir.version}
SUNW_Pkg:           SUNWgir-repository
IPS_package_name:   library/desktop/gobject/gir-repository
Meta(info.classification): %{classification_prefix}:Development/GNOME and GTK+
SUNW_BaseDir:       %{_basedir}
SUNW_Copyright:     %{name}.copyright
SUNW_BaseDir:       %{_basedir}
BuildRoot:          %{_tmppath}/%{name}-%{version}-build

BuildRequires:      SUNWPython26-devel
BuildRequires:      SUNWavahi-bridge-dsd-devel
BuildRequires:      SUNWbabl-devel
BuildRequires:      SUNWdbus-devel
BuildRequires:      SUNWgegl-devel
BuildRequires:      SUNWgtk2-devel
BuildRequires:      SUNWlibatk-devel
BuildRequires:      SUNWlibsoup-devel
BuildRequires:      SUNWlibunique-devel
BuildRequires:      SUNWgnome-config-devel
BuildRequires:      SUNWgnome-file-mgr-devel
BuildRequires:      SUNWgnome-gtksourceview-devel
BuildRequires:      SUNWgnome-libs-devel
BuildRequires:      SUNWgnome-media-devel
BuildRequires:      SUNWgnome-panel-devel
BuildRequires:      SUNWgnome-pdf-viewer-devel
BuildRequires:      SUNWgnome-terminal-devel
BuildRequires:      SUNWpango-devel
BuildRequires:      SUNWgobject-introspection-devel
Requires:           SUNWPython26
BuildRequires:      SUNWavahi-bridge-dsd
Requires:           SUNWbabl
Requires:           SUNWdbus
Requires:           SUNWgegl
Requires:           SUNWgtk2
Requires:           SUNWlibatk
Requires:           SUNWlibsoup
Requires:           SUNWlibunique
Requires:           SUNWgnome-config
Requires:           SUNWgnome-file-mgr
Requires:           SUNWgnome-gtksourceview
Requires:           SUNWgnome-libs
Requires:           SUNWgnome-media
Requires:           SUNWgnome-panel
Requires:           SUNWgnome-pdf-viewer
Requires:           SUNWgnome-terminal
Requires:           SUNWpango
Requires:           SUNWgobject-introspection
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gir.prep -d %name-%version

%build
export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
# The VTE bindings uses libncurses.  The VTE bindings do not build
# if it can't find libncurses.
export LD_LIBRARY_PATH="/usr/gnu/lib"

%gir.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%gir.install -d %name-%version

# selectively delete some files delivered by another package
for t in girepository-1.0/Atk-1.0.typelib girepository-1.0/GMenu-2.0.typelib \
         girepository-1.0/Gdk-2.0.typelib girepository-1.0/GdkPixbuf-2.0.typelib \
         girepository-1.0/Gtk-2.0.typelib girepository-1.0/Wnck-1.0.typelib
do
  rm $RPM_BUILD_ROOT/%{_libdir}/$t
done

for g in gir-1.0/Atk-1.0.gir gir-1.0/GMenu-2.0.gir gir-1.0/Gdk-2.0.gir \
         gir-1.0/GdkPixbuf-2.0.gir gir-1.0/Gtk-2.0.gir gir-1.0/Pango-1.0.gir \
         gir-1.0/PangoCairo-1.0.gir gir-1.0/PangoFT2-1.0.gir \
         gir-1.0/PangoXft-1.0.gir gir-1.0/Wnck-1.0.gir
do
  rm $RPM_BUILD_ROOT/%{_datadir}/$g
done

# delivered by gnome-config
rm $RPM_BUILD_ROOT/%{_libdir}/girepository-1.0/GConf-2.0.typelib
rm $RPM_BUILD_ROOT/%{_datadir}/gir-1.0/GConf-2.0.gir

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%{_libdir}/*.so
%{_libdir}/girepository-1.0/*.typelib
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gir-1.0/*.gir
%doc -d gir-repository-%{version} AUTHORS README NEWS
%doc(bzip2) -d gir-repository-%{version} COPYING
%dir %attr (0755, root, other) %{_datadir}/doc

%changelog
* Thu Apr 22 2010 - [email protected]
- Fix %files.
* Tue Apr 06 2010 - [email protected]
- Add back .typelib and .gir files
- Add SUNW_Pkg and IPS_package_name
* Mon Aug 24 2009 - [email protected]
- Move from SFE, spilit base part to base-specs/gir-repository
* Mon Aug 03 2009 - Brian Cameron  <[email protected]>
- Now build with 0.6.3 tarball.
* Sat Apr 04 2009 - Brian.Cameron  <[email protected]>
- Created.