Solaris/SUNWgnome-games.spec
author bc99092
Mon, 10 May 2004 17:13:24 +0000
changeset 2702 f212dce16208
parent 2621 ffa9546fd848
child 2896 1bfc88eef0da
permissions -rw-r--r--
2004-05-10 Brian Cameron <[email protected]> * Putting back %{_sysconfig}/gconf into packaging which got accidently simplified away in Laca's last change. Now the games work again.

#
# spec file for package SUNWgnome-games
#
# includes module(s): gnome-games
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use gnome_games = gnome-games.spec

Name:                    SUNWgnome-games
Summary:                 GNOME Games
Version:                 2.6.0
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires: SUNWgnome-javahelp-convert
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs

%package share
Summary:                 GNOME Games - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWpl5u

%package root
Summary:                 GNOME Games - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%package devel
Summary:                 GNOME Games - developer files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gnome_games.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_libdir}/pkgconfig:/usr/lib/pkgconfig
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="-L%{_libdir} -R%{_libdir}"

%gnome_games.build -d %name-%version

%install
%gnome_games.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}

for f in apps/?gconf.xml \
         schemas/?gconf.xml \
         schemas/apps/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_prefix}
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/gnome-stones/objects/lib*.so*
%{_libexecdir}/gnome-poetry

%files share
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_prefix}
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/applications
%{_datadir}/gnect
%{_datadir}/gnibbles
%{_datadir}/gnobots2
%{_datadir}/gnome-stones
%{_datadir}/gnome/help/*/C
%{_datadir}/gnome/javahelp/*/C
%{_datadir}/mime-info
%{_datadir}/omf/*/*-C.omf
%{_datadir}/pixmaps
%{_datadir}/sounds
%{_datadir}/gnome-stonesrc

%files root
%attr(0755, root, sys) %dir %{_sysconfdir}
%dir %attr (0755, root, bin) %{_prefix}
%defattr (-, root, other)
%{_sysconfdir}/sound
%{_sysconfdir}/gconf
%defattr(0755, root, sys)

%files devel
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_prefix}
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/gdkcardimage

%changelog
* Mon May 10 2004 - [email protected]
- Putting back %{_sysconfig}/gconf into packaging which got 
  accidently simplified away in Laca's last change.  Now the
  games work again.
* Tue Apr 20 2004 - [email protected]
- simlify %files
- add javahelp
* Thu Apr 08 2004 - [email protected]
- added missing %defattr
* Fri Mar 26 2004 - [email protected]
- Created,