SUNWgnome-desklets-extra.spec
author jerrytan
Mon, 11 Aug 2008 07:35:57 +0000
branchgnome-2-22
changeset 12497 f4743e0d8120
parent 12474 d567bb22cd30
permissions -rw-r--r--
update spec for tracker from vermillion

#
# spec file for package SUNWgnome-desklets-extra
#
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: bewitche
#


%include Solaris.inc
%use gd_calendar = gdesklets-calendar.spec
%use gd_clock = gdesklets-clock.spec
%use gd_worldtime = gdesklets-worldtime.spec

Name:                    SUNWgnome-desklets-extra
Summary:                 Supplied Gnome desktop widgets
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

Requires: SUNWgnome-desklets
Requires: SUNWgnome-desktop-prefs
Requires: SUNWgnome-libs
Requires: SUNWpostrun
BuildRequires: SUNWgnome-desktop-prefs-devel
BuildRequires: SUNWgnome-libs-devel

%description

%prep
rm -rf %name-%version
mkdir %name-%version

%build
# we just get the bits tarball from developer

%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gdesklets/Controls
mkdir -p $RPM_BUILD_ROOT%{_datadir}/gdesklets/Displays
%gd_calendar.install -d %name-%version
%gd_clock.install -d %name-%version
%gd_worldtime.install -d %name-%version

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%files
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, bin) %{_datadir}/gdesklets
%{_datadir}/gdesklets/*

%changelog
* Wed Jul 16 2008 - [email protected]
- Add rm/mkdir to %prep because build requires that the dir exists.

* Tue Jul 15 2008 - [email protected]
- Break gdesklets-extra.spec into three spec files (one for each desklet).
  Change this file to use each of the spec files.

* Thu Feb  8 2007 - [email protected]
- Update dependency list for files used in %post and during build.

* Mon Feb  5 2007 - [email protected]
- Add %prep section to create dir in BUILD dir.

* Thu Jan 29 2007 - <[email protected]>
- initial creation