SUNWgnome-desklets.spec
author jerrytan
Mon, 11 Aug 2008 07:35:57 +0000
branchgnome-2-22
changeset 12497 f4743e0d8120
parent 12417 653d3619d81e
child 13619 d1eccd3364d8
permissions -rw-r--r--
update spec for tracker from vermillion

#
# # spec file for package SUNWgnome-desklets
#
# includes module(s): gdesklets
#
# Copyright (c) 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: bewitche
#
%include Solaris.inc

%use gdesklets = gdesklets.spec

Name:                    SUNWgnome-desklets
Summary:                 GNOME desktop widgets engine
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires: SUNWPython
Requires: SUNWgnome-libs
Requires: SUNWlibrsvg
Requires: SUNWgnome-python-desktop
Requires: SUNWgnome-python-libs
Requires: SUNWgnome-desktop-prefs
Requires: SUNWpostrun
BuildRequires: SUNWPython-devel
BuildRequires: SUNWgnome-desktop-prefs-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-python-desktop-devel
BuildRequires: SUNWgnome-python-libs-devel
BuildRequires: SUNWlibrsvg-devel

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%gdesklets.prep -d %name-%version

%build
export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
%gdesklets.build -d %name-%version

%install
%gdesklets.install -d %name-%version 

# Change %{_bindir}/gdesklets symlink to a relative one.
cd $RPM_BUILD_ROOT%{_bindir}
rm gdesklets
ln -s  ../lib/gdesklets/gdesklets

# fixes %_datadir/gdesklets/Displays/Calendar/gfx/months/README
chmod -R a+rX $RPM_BUILD_ROOT

rm -r $RPM_BUILD_ROOT%{_datadir}/mime
rm $RPM_BUILD_ROOT%{_datadir}/applications/*.cache

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif


%clean
rm -rf $RPM_BUILD_ROOT

%post
%include desktop-database-install.script
%include scrollkeeper-update.script
%include icon-cache.script

%postun
test -x $BASEDIR/lib/postrun || exit 0
%include desktop-database-uninstall.script
%include scrollkeeper-update.script

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gdesklets
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*.desktop
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%dir %attr (0755, root, bin) %{_mandir}
%{_mandir}/*
%dir %attr (0755, root, other) %{_datadir}/icons
%dir %attr (0755, root, other) %{_datadir}/icons/gnome
%dir %attr (0755, root, other) %{_datadir}/icons/gnome/48x48
%dir %attr (0755, root, other) %{_datadir}/icons/gnome/48x48/mimetypes
%{_datadir}/icons/gnome/48x48/mimetypes/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif


%changelog
* Wed Jun 04 2008 - [email protected]
- Make %{_bindir}/gdesklets a relative symlink as absolute symlinks are not
  permitted by Solaris WOS.
* Mon Oct 15 2007 - [email protected]
- make all files in the package readable
* Thu Oct 11 2007 - [email protected]
- Use desktop-database-install.script for %post
  and desktop-database-uninstall.script for %postun
* Thu Oct 11 2007 - [email protected]
- Change the inline postinstall script to an include
* Thu Mar 22 2007 - [email protected]
- Change %{_datadir}/icons/gnome/48x48/mimetypes attr to root:other.
* Thu Feb  8 2007 - [email protected]
- Update dependency list for files used in %post and during build.
* Mon Feb  5 2007 - [email protected]
- Set %dir %attr for icons dirs.
- Remove 'rm -rf $RPM_BUILD_ROOT' from %install as it is not needed.
* Thu Jan 29 2007 - <[email protected]>
- initial creation