Solaris/SUNWgnome-desktop-prefs.spec
author bc99092
Thu, 22 Sep 2005 02:47:58 +0000
changeset 5985 f76fe04a88a0
parent 5859 da89f4e343b9
child 6094 8a3298e55929
permissions -rw-r--r--
2005-09-21 Brian Cameron <[email protected]> * control-center.spec: Disable scrollkeeper and add patch 19 so it builds if xcursor is not available. * gst.spec, gst-plugins.spec: Bump to 0.8.11. * gdm.spec: Bump to 2.8.0.4 * SUNWgnome-base-libs.spec: No longer comment out postprocess, I accidently committed this. * SUNWgnome-desktop-prefs.spec: Fix packaging. * SUNWgnome-media.spec: Add SUNWogg-vorbis-devel to BuildRequires * SUNWgnome-media-apps.spec: Fix packaging * extra-specs/libvorbis.spec: Bump to 1.1.1.

#
# spec file for package SUNWgnome-desktop-prefs
#
# includes module(s): control-center
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%use dfu = desktop-file-utils.spec
%use cc = control-center.spec

Name:                    SUNWgnome-desktop-prefs
Summary:                 GNOME desktop wide preference configuration tools - platform dependent files, /usr filesystem
Version:                 %{default_pkg_version}
Source:                  gnome-accessibility-keyboard-properties.1
Source1:                 gnome-background-properties.1
Source2:                 gnome-control-center.1
Source3:                 gnome-default-applications-properties.1
Source4:                 gnome-desktop-prefs.1
Source5:                 gnome-file-types-properties.1
Source6:                 gnome-font-properties.1
Source7:                 gnome-keybinding-properties.1
Source8:                 gnome-keyboard-properties.1
Source9:                 gnome-mouse-properties.1
Source10:                gnome-network-preferences.1
Source11:                gnome-settings-daemon.1
Source12:                gnome-sound-properties.1
Source13:                gnome-theme-manager.1
Source14:                gnome-ui-properties.1
Source15:                gnome-window-properties.1
Source16:                gnome-at-properties.1
Source17:                gnome-font-viewer.1
Patch1:                  control-center-01-solaris-printmgr.diff
Patch2:                  control-center-02-sun-volume-keys.diff
Patch3:                  control-center-03-sun-help-key.diff
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-desktop-prefs-root
Requires: SUNWgnome-desktop-prefs-share
# requires panel due to libxklavier dependency.
Requires: SUNWgnome-panel
Requires: SUNWgnome-file-mgr
Requires: SUNWgnome-libs
Requires: SUNWgnome-wm
Requires: SUNWxwrtl
Requires: SUNWxorg-clientlibs
BuildRequires: SUNWgnome-wm-devel
BuildRequires: SUNWxorg-headers
BuildRequires: SUNWtltk

%package share
Summary:                 GNOME desktop wide preference configuration tools - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%package root
Summary:                 GNOME desktop wide preference configuration tools - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%package  devel
Summary:                 GNOME desktop wide preference configuration tools development files  - platform dependent files, /usr
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-desktop-prefs
                                                                                
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%prep
rm -rf %name-%version
mkdir %name-%version
%dfu.prep -d %name-%version
%cc.prep -d %name-%version
cd %{_builddir}/%name-%version/control-center-%{cc.version}
%patch1 -p1
%ifarch sparc
%patch2 -p1
%patch3 -p1
%endif
cd ..

%build
export CFLAGS="%optflags -I/usr/sfw/include -I/usr/X11/include -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
export PKG_CONFIG_PATH=%{_pkg_config_path}
#FIXME: This stuff should be fixed in the component or the configure script
export LDFLAGS="-L/usr/X11/lib -R/usr/X11/lib -L/usr/sfw/lib -R/usr/sfw/lib -lfreetype"
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int

%dfu.build -d %name-%version
%cc.build -d %name-%version

%install
%dfu.install -d %name-%version
export PATH=%{_builddir}/%name-%version/desktop-file-utils-%{dfu.version}/src:$PATH
%cc.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
for f in apps/?gconf.xml \
         desktop/?gconf.xml \
         desktop/gnome/?gconf.xml \
         desktop/gnome/peripherals/?gconf.xml \
         desktop/gnome/peripherals/keyboard/?gconf.xml \
         desktop/gnome/thumbnailers/?gconf.xml \
         schemas/?gconf.xml \
         schemas/apps/?gconf.xml \
         schemas/desktop/?gconf.xml \
         schemas/desktop/gnome/?gconf.xml \
         schemas/desktop/gnome/peripherals/?gconf.xml \
         schemas/desktop/gnome/peripherals/keyboard/?gconf.xml \
         schemas/desktop/gnome/thumbnailers/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done
rm -rf $RPM_BUILD_ROOT%{_mandir}
install -d $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE0 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE7 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE8 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE9 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE10 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE11 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE12 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE13 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE14 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE15 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE16 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE17 $RPM_BUILD_ROOT%{_mandir}/sman1
touch $RPM_BUILD_ROOT/%{_datadir}/applications/screensaver-properties.desktop
mkdir $RPM_BUILD_ROOT/%{_datadir}/control-center-2.0/capplets
cd $RPM_BUILD_ROOT/%{_datadir}/control-center-2.0/capplets
ln -s ../../applications/screensaver-properties.desktop .
rm $RPM_BUILD_ROOT/%{_datadir}/applications/screensaver-properties.desktop

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/bonobo
%{_libdir}/gnome-vfs-2.0/modules/*.so
%{_libdir}/nautilus
%{_libdir}/window-manager-settings/*.so
%{_libexecdir}/gnome-settings-daemon
%{_libexecdir}/solaris-printmgr-wrapper

%files share
%defattr (-, root, other)
%dir %attr(0755, root, sys) %{_datadir}
%{_datadir}/applications
%{_datadir}/control-center-2.0
%{_datadir}/emacs
%{_datadir}/gnome
%{_datadir}/gnome-background-properties
%{_datadir}/icons
%{_datadir}/idl
%{_datadir}/omf
%{_datadir}/pixmaps
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files devel
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/pkgconfig
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%files root
%attr (0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/*
%defattr (0755, root, sys)

%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale

%changelog
* Tue Jul 19 2005 - [email protected]
- Add BuildRequires SUNWtltk because build was breaking without that package.
* Wed Jul 13 2005 - [email protected]
- Added SUNWgnome-panel dependency
* Thu Jun 02 2005 - [email protected]
- Bumped to 2.10, fixed packaging.
* Tue Oct 26 2004 - [email protected]
- Added patch control-center-03-sun-help-key.diff (to sparc only) to bind the 
  Sun help key to launch default help with Sun tpe Keyboards. Fixes the bugtraq 
  bug#6182405.
* Tue Oct 19 2004 - [email protected]
- Added patch control-center-02-sun-volume-keys.diff (to sparc only) to bind 
  Sun keys Volume up, Volume Down and Volume Mute to control volume with Sun type
  keyboards. Fixes bugtraq bug#6173921.
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Sat Sep 11 2004 - [email protected]
- Set LDFLAGS so Xrandr and Xrender can be found.
* Thu Sep 09 2004 - [email protected]
- Added gnome-at-properties.1, gnome-font-viewer.1 manpages
* Wed Aug 18 2004 - [email protected]
- Change manpage perms for Solaris integration.
* Fri Aug  6 2004 - [email protected]
- Add support for running the Solaris Print Manager (as root)
* Tue Jul 13 2004 - [email protected]
- Create symlink to screensaver-properties.desktop in capplets dir to fix
  bug 5070633.
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Tue Mar 02 2004 - [email protected]
- add {_libdir}/window-manager-settings
* Mon Mar 01 2004 - [email protected]
- remove libxklavier
- add dependency on SUNWgnome-wm
* Mon Feb 23 2004 - [email protected]
- install gconf schemas at the end of the install
  stage.
* Thu Feb 19 2004 - [email protected]
- initial Solaris spec file