base-specs/gnome-keyring.spec
author dcarbery
Fri, 18 Jan 2008 14:54:13 +0000
changeset 11487 f90eda610ae3
parent 11477 18198fb39803
child 11489 82a5f6080b74
permissions -rw-r--r--
2008-01-18 Damien Carbery <[email protected]> * SUNWevolution.spec: Add evolution-backup to %files. * base-specs/gnome-keyring.spec: Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.

#
# spec file for package gnome-keyring
#
# Copyright (c) 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: gheet
#
Name:         gnome-keyring
License:      GPL
Group:        System/GUI/GNOME
Version:      2.20.3
Release:      4
Distribution: Java Desktop System
Vendor:	      Sun Microsystems, Inc.
Summary:      GNOME Key Ring
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.21/%{name}-%{version}.tar.bz2
#owner:dcarbery date:2007-07-31 type:bug bugzilla:462122
Patch1:       gnome-keyring-01-strsep.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define gtk2_version 2.4.0
%define pkgconfig_version 0.15.0
%define gtk_doc_version 1.1

Requires: gtk2 >= %{gtk2_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: gtk-doc >= %{gtk_doc_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}

%description
gnome-keyring is a program that keep password and other secrets for
users. It is run as a daemon in the session, similar to ssh-agent, and
other applications can locate it by an environment variable.
                                                                                                                                                             
The program can manage several keyrings, each with its own master
password, and there is also a session keyring which is never stored to
disk, but forgotten when the session ends.
                                                                                                                                                             
The library libgnome-keyring is used by applications to integrate with
the gnome keyring system.

%package devel
Summary:      GNOME Key Ring Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     gtk2-devel >= %{gtk2_version}

%description devel
gnome-keyring is a program that keep password and other secrets for
users. It is run as a daemon in the session, similar to ssh-agent, and
other applications can locate it by an environment variable.
                                                                                                                                                             
The program can manage several keyrings, each with its own master
password, and there is also a session keyring which is never stored to
disk, but forgotten when the session ends.
                                                                                                                                                             
The library libgnome-keyring is used by applications to integrate with
the gnome keyring system.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
intltoolize -f -c --automake
aclocal $ACLOCAL_FLAGS -I .
autoconf
autoheader
automake -a -c -f

CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
	    --mandir=%{_mandir}			\
	    --disable-pam			\
            --libexecdir=%{_libexecdir}

# FIXME: hack: stop the build from looping
touch po/stamp-it

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%{_datadir}/locale/*/LC_MESSAGES/*
%{_bindir}/*
%{_libdir}/lib*.so.*
%{_libexecdir}/gnome-keyring-ask

%files devel
%{_libdir}/pkgconfig/*.pc
%{_includedir}/gnome-keyring-1/*
%{_libdir}/lib*.so

%changelog
* Fri Jan 18 2008 - [email protected]
- Revert to 2.20.3 because the AM_PATH_LIBTASN1 macro is unavailable.

* Thu Jan 17 2008 - [email protected]
- Bump to 2.21.5.

* Mon Jan 07 2008 - [email protected]
- Bump to 2.20.3.

* Wed Dec 19 2007 - [email protected]
- Version unbumped to 2.20 by damien but download directory 
  was still 2.21. Fixed by changing to /pub/SOURCES/2.20

* Tue Dec 18 2007 - [email protected]
- Bump to 2.21.4.

* Tue Nov 27 2007 - [email protected]
- Bump to 2.20.2.

* Fri Oct 19 2007 - [email protected]
- Bump to 2.20.1. Remove upstream patch, 02-new-keyring-bug.

* Tue Sep 18 2007 - [email protected]
- Bump to 2.20.0. Remove upstream patch, 02-export-symbols. Renumber rest.

* Thu Sep 13 2007 - [email protected]
- Added patch for bugzilla bug: 476644, which presents issues when creating a
  new keyring where non existed before : gnome-keyring-03-new-keyring-bug.diff

* Wed Sep 05 2007 - [email protected]
- Bump to 2.19.91.
- Add patch 02-export-symbols for bugzilla #473796
- Remove upstream patches, XX-err_to_g_error and XX-string_header

* Thu Aug 16 2007 - [email protected]
- Unbump to 2.19.6.1 because of build error I cannot figure out.

* Wed Aug 15 2007 - [email protected]
- Bump to 2.19.90. Remove upstream patches, 01-err_to_g_error and
  02-string_header.

* Mon Jul 30 2007 - [email protected]
- Add 3 patches, 01-err_to_g_error, 02-string_header and 03-strsep to fix
  Solaris specific build issues.

* Tue Jul 31 2007 - [email protected]
- Bump to 2.19.6.1.

* Mon Jul 30 2007 - [email protected]
- Bump to 2.19.6. Remove upstream patch, 01-suncc-build-fail.

* Mon Jul 09 2007 - [email protected]
- Bump to 2.19.5.
- Add patch suncc-build-fail.diff to let build pass.

* Tue Jun 19 2007 - [email protected]
- Bump to 2.19.4.1.

* Mon Jun 18 2007 - [email protected]
- Bump to 2.19.4.

* Tue May 15 2007 - [email protected]
- Bump to 2.19.2. Remove unneeded patch, 01-pkcs. gnome-keyring uses libgcrypt
  now.

* Sun Apr 08 2007 - [email protected]
- Bump to 0.8.1. Remove upstream patch, 02-crash.

* Tue Mar 27 2007 - [email protected]
- Add patch crash.diff.

* Mon Mar 12 2007 - [email protected]
- Bump to 0.8.

* Tue Mar 06 2007 - [email protected]
- Bump to 0.7.92.

* Tue Feb 13 2007 - [email protected]
- Bump to 0.7.91.

* Fri Jan 05 2007 - [email protected]
- Bump to 0.7.3.

* Tue Dec 19 2006 - [email protected]
- Bump to 0.7.2.

* Wed Dec 06 2006 - [email protected]
- Add intltoolize to read LIGUAS file. Fixes 6498950

* Mon Sep 04 2006 - [email protected]
- Bump to 0.6.0.

* Fri Jul 20 2006 - [email protected]
- Bump to 0.5.1.

* Tue May 02 2006 - [email protected]
- Remove unneeded intltoolize call.

* Mon Mar 13 2006 - [email protected]
- Bump to 0.4.9.

* Tue Feb 28 2006 - [email protected]
- Bump to 0.4.8.

* Mon Feb 13 2006 - [email protected]
- Bump to 0.4.7.
- Add hack to fix infinite loop problem in po/Makefile.

* Tue Nov 29 2005 - [email protected]
- Bump to 0.4.6.

* Thu Sep 15 2005 - [email protected]
- Bump to 0.4.5.

* Fri Sep 09 2005 - [email protected]
- call intltoolize so that the correct Makefile.in.in is copied to po

* Tue Sep 06 2005 - [email protected]
- Call glib-gettextize as po/Makefile.in.in not in tarball. Add patch to
  skip the 'ar' locale as its files has problems #315335.

* Mon Sep 05 2005 - [email protected]
- Bump to 0.4.4.

* Mon Aug 15 2005 - [email protected]
- Bump to 0.4.3.

* Wed Jun 15 2005 - [email protected]
- Add more libs to LDADD so that it builds with the new pkgconfig

* Fri May 06 2005 - [email protected]
- Bump to 0.4.2

* Fri Aug 29 2004 - [email protected]
- Added patch 01 for pkcs support.

* Wed Aug 18 2004 - [email protected]
- removed --disable-gtk-doc since this isn't an option this module's
  configure takes.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-keyring-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to gnome-keyring-l10n-po-1.1.tar.bz2

* Tue Apr 13 2004 - [email protected]
- upgraded tarball
* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gnome-keyring-l10n-po-1.0.tar.bz2 l10n content

* Fri Mar 19 2004 - [email protected]
- Bump to 0.1.91 and remove the uninstalled pc patch
  since it's upstream.

* Fri Mar 12 2004 - [email protected]
- define libexecdir in configure args

* Mon Feb 02 2004 - [email protected]
- bump to 0.1.2
- Add patch to generate an -uninstalled.pc file
- Add ACLOCAL_FLAGS env to aclocal invocation

* Mon Dec 15 2003 - [email protected]
- Initial Sun release