libsoup.spec
author dermotm
Mon, 09 May 2005 09:37:53 +0000
changeset 5415 fd7c7e0f351b
parent 5414 219255e89582
child 5458 4c7bf791deca
permissions -rw-r--r--
bump src tarballs for moz/evo/apoc

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build35-linux-cb
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

Name:     	libsoup
Version: 	1.99.23
Release:	376
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	LGPL/GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
Source1:		l10n-configure.sh
Patch:          libsoup-01-gnutls_cert_corrupted.diff

%define libxml2_devel_version 2.4.23
%define glib2_version 2.0

BuildRequires:	glibc-devel
BuildRequires:	libtool
BuildRequires:	glib2-devel
BuildRequires:	libxml2-devel >= %{libxml2_devel_version}
BuildRequires:	popt
BuildRequires:	zlib-devel
BuildRequires:	gnutls-devel	
Summary:	Simple Object Access Protocol implementation
Group:		System Environment/Libraries
Requires:	glib2 >= %{glib2_version}
Requires:	popt
Requires:	libxml2

%description
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

%files
%defattr(-, root, root)
%doc COPYING ChangeLog AUTHORS INSTALL NEWS TODO README
%{_libdir}/lib*.so.*


%post
ldconfig

%package -n libsoup-devel
Summary:	Simple Object Access Protocol implementation
Group:		Development/Libraries
Requires:	%{name} = %{version}-%{release}
Requires:	glib2-devel
Requires:	libxml2-devel

%description -n libsoup-devel
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

This package allows you to develop applications that use the Soup library.

%files -n libsoup-devel
%defattr(-, root, root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*


# $RPM_COMMAND is an environment variable used by the SUN build
# system to control the build process with finer granularity than RPM
# normally allows.  This specfile will function as expected by RPM if
# $RPM_COMMAND is unset.  If you are not the SUN build system,
# feel free to ignore it.

%prep
case "${RPM_COMMAND:-all}" in
dist)
%setup  -q -D -n %{name}-%{version}
    ;;
all)
%setup  -q -n %{name}-%{version}
    ;;
esac
%patch -p1

bash -x %SOURCE1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND DESTDIR ARCH
case "$RPM_COMMAND" in
prepare|all)
    libtoolize
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    autoheader
    automake -a -f -c
    autoconf
    ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir} \
	--infodir=%{_datadir}/info \
	--localstatedir=/var \
	--enable-more-warnings=no \
	--enable-gtk-doc=no  \
	--with-gnutls-libs=%{_libdir} \
	--with-gnutls-includes=%{_includedir}
    ;;
esac
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE} -j $CPUS
    ;;
esac

%install
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
# export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
    ${MAKE} install prefix=${DESTDIR}%{_prefix} sysconfdir=${DESTDIR}%{_sysconfdir} mandir=${DESTDIR}%{_mandir} infodir=${DESTDIR}%{_datadir}/info localstatedir=${DESTDIR}/var
    rm $RPM_BUILD_ROOT%{_libdir}/*.a
    rm $RPM_BUILD_ROOT%{_libdir}/*.la
    ;;
esac

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac


%changelog
* Mon May 09 2005 - [email protected]
- Bump source tarball to build 35 (linux)

* Mon Apr 25 2005 - [email protected]
- Bump source tarball to build 34 (linux)

* Mon Apr 11 2005 - [email protected]
- Bump source tarball to build 33 (linux)

* Mon Mar 28 2005 - [email protected]
- Bump source tarball to build 32 (linux)

* Mon Mar 14 2005 - [email protected]
- Bump source tarball to build 31 (linux)

* Mon Feb 28 2005 - [email protected]
- Bump source tarball to build 30 (linux)

* Mon Feb 14 2005 - [email protected]
- Bump source tarball to build 29 (linux)

* Mon Jan 31 2005 - [email protected]
- Bump source tarball to build 28 (linux)

* Mon Jan 17 2005 - [email protected]
- Bump source tarball to build 27 (linux)

* Tue Jan 04 2005 - [email protected]
- Bump source tarball to build 26 (linux)

* Mon Dec 13 2004 - [email protected]
- Bump source tarball to build 25 (linux)

* Mon Nov 29 2004 - [email protected]
- Bump source tarball to build 24

* Mon Nov 15 2004 - [email protected]
- Bump source tarball to build 23.

* Mon Nov 01 2004 - [email protected]
- bump src tarball to build22

* Mon Oct 18 2004 - [email protected]
- bump src tarball to build21

* Mon Oct 11 2004 - [email protected]
- bump src tarball to build20b

* Mon Sep 20 2004 - [email protected]
- bump src tarball to build19

* Mon Sep 06 2004 - [email protected]
- bump src tarball to build18

* Mon Aug 23 2004 - [email protected]
- bump src tarball to build17

* Mon Aug 09 2004 - [email protected]
- bump src tarball to build16

* Mon Jul 26 2004 - [email protected]
- bump src tarball to build15

* Mon Jul 19 2004 - [email protected]
- rpm4 fixes
- add patch to build with gnutls without GNUTLS_CERT_CORRUPTED

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12
* Sun May 30 2004 - [email protected]
- bump src tarball to build11
* Fri May 14 2004 - [email protected]
- bump src tarball to build10
* Fri Apr 30 2004 - [email protected]
- bump src tarball to build09