Solaris/SUNWgnome-remote-desktop.spec
author dc144907
Fri, 30 Sep 2005 12:41:31 +0000
changeset 6049 fe7a9d6bdb3b
parent 5859 da89f4e343b9
child 6102 1e3e35b9a369
permissions -rw-r--r--
* vino.spec: Add patch to move a #include outside '#ifdef HAVE_GNUTLS' code so that it builds. Bugzilla: 315459. * patches/vino-02-libgnomeui-include.diff: Added. Bugzilla: 315459. * SUNWgnome-remote-viewer.spec: Add applications and icons dirs under %{_datadir}.

#
# spec file for package SUNWgnome-remote-desktop
#
# includes module(s): vino
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use vino = vino.spec

Name:                    SUNWgnome-remote-desktop
Summary:                 GNOME Remote Desktop
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs

%package share
Summary:                 GNOME Remote Desktop - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWperl584usr

%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%package root
Summary:                 GNOME Remote Desktop - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%prep
rm -rf %name-%version
mkdir %name-%version
%vino.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="-L/usr/sfw/lib -R/usr/sfw/lib"

%vino.build -d %name-%version

%install
%vino.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
for f in desktop/?gconf.xml \
         desktop/gnome/?gconf.xml \
         schemas/?gconf.xml \
         schemas/desktop/?gconf.xml \
         schemas/desktop/gnome/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/vino-server
%{_libdir}/bonobo/servers/GNOME_RemoteDesktop.server

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gnome/vino
%{_datadir}/applications
%{_datadir}/icons

%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale

%files root
%attr (0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/gconf
%defattr (0755, root, sys)

%changelog
* Fri Sep 30 2005 - [email protected]
- Add applications and icons dirs under %{_datadir}.
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Thu Jun 23 2004 - [email protected]
- more changes for change install location to /usr/lib and /usr/bin
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Fri May 07 2004 - [email protected]
- Removed locale/C from "%files share" since it doesn't
  exist.
* Thu Apr 15 2004 - [email protected]
- Created,