CBEcoreutils.spec
changeset 1 102c9870ef63
child 7 fe5233293a17
equal deleted inserted replaced
0:680d43556a9a 1:102c9870ef63
       
     1 #
       
     2 # spec file for package CBEcoreutils
       
     3 #
       
     4 # Copyright 2008 Sun Microsystems, Inc.
       
     5 # This file and all modifications and additions to the pristine
       
     6 # package are under the same license as the package itself.
       
     7 #
       
     8 
       
     9 %include CBE.inc
       
    10 
       
    11 Name:			CBEcoreutils
       
    12 License:		GPL
       
    13 Group:			system/cbe
       
    14 Version:		6.10
       
    15 Release:		1
       
    16 Distribution:		JDS CBE
       
    17 Vendor:			Sun Microsystems, Inc.
       
    18 Summary:		JDS CBE: GNU coreutils
       
    19 Source:			ftp://ftp.gnu.org/pub/gnu/coreutils/coreutils-%{version}.tar.gz
       
    20 URL:			http://www.gnu.org/software/coreutils
       
    21 BuildRoot:		%{_tmppath}/%{name}-%{version}-build
       
    22 SUNW_BaseDir:		%{_prefix}
       
    23 SUNW_Category:          JDS,CBE,application
       
    24 SUNW_Rev:               @CBE_VERSION@
       
    25 %include default-depend.inc
       
    26 
       
    27 %description
       
    28 GNU coreutils for the JDS build environment
       
    29 
       
    30 %prep
       
    31 %setup -q -n coreutils-%{version}
       
    32 
       
    33 %build
       
    34 CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
       
    35 if test "x$CPUS" = "x" -o $CPUS = 0; then
       
    36   CPUS=1
       
    37 fi
       
    38 export LINGUAS="xx"
       
    39 %define _mandir %{_datadir}/man
       
    40 CFLAGS="$RPM_OPT_FLAGS -xc99"			\
       
    41 ./configure --prefix=%{_prefix} --mandir=%{_mandir}
       
    42 make -j$CPUS
       
    43 
       
    44 %install
       
    45 rm -rf $RPM_BUILD_ROOT
       
    46 make install DESTDIR=$RPM_BUILD_ROOT
       
    47 rm -rf $RPM_BUILD_ROOT%{_libdir}
       
    48 rm -rf $RPM_BUILD_ROOT%{_prefix}/info
       
    49 
       
    50 %clean
       
    51 rm -rf $RPM_BUILD_ROOT
       
    52 
       
    53 %files
       
    54 %defattr(-, root, bin)
       
    55 %dir %attr (0755, root, bin) %{_bindir}
       
    56 %{_bindir}/*
       
    57 %dir %attr (0755, root, sys) %{_datadir}
       
    58 %{_datadir}/*
       
    59 
       
    60 %changelog
       
    61 * Mon Apr 14 2008 - [email protected]
       
    62 - update deps
       
    63 - use CBE.inc
       
    64 * Mon Mar  3 2008 - [email protected]
       
    65 - rename to CBEcoreutils (from CBEfileutils) and bump to 6.10
       
    66 * Tue Aug 22 2006  <[email protected]>
       
    67 - fix %files attributes
       
    68 - move to /opt/jdsbld by default
       
    69 * Wed Aug 16 2006  <[email protected]>
       
    70 - add missing deps
       
    71 * Tue Aug  1 2006 - [email protected]
       
    72 - add -xc99 (fix from Doug Scott)
       
    73 * Fri Sep 02 2004  <[email protected]>
       
    74 - remove unpackaged files
       
    75 * Sun Sep 05 2004  <[email protected]>
       
    76 - enable parallel build
       
    77 * Fri Mar 05 2004  <[email protected]>
       
    78 - fix %files
       
    79 - change the pkg category