CBElibtool.spec
changeset 1 102c9870ef63
child 7 fe5233293a17
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/CBElibtool.spec	Mon Apr 14 10:39:56 2008 +0000
@@ -0,0 +1,87 @@
+#
+# spec file for package CBElibtool
+#
+# Copyright 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%include CBE.inc
+
+Name:			CBElibtool
+License:		GPL
+Group:			system/cbe
+Version:		1.5.26
+Release:		1
+Distribution:		JDS CBE
+Vendor:			Sun Microsystems, Inc.
+Summary:		JDS CBE: GNU libtool
+Source:			ftp://ftp.gnu.org/pub/gnu/libtool/libtool-%{version}.tar.gz
+URL:			http://www.gnu.org/
+BuildRoot:		%{_tmppath}/%{name}-%{version}-build
+SUNW_BaseDir:		%{_prefix}
+SUNW_Category:          JDS,CBE,application
+SUNW_Rev:               @CBE_VERSION@
+Requires:               SUNWcsl
+Requires:               SUNWperl584core
+
+%description
+GNU libtool for the JDS build environment
+
+%prep
+%setup -q -n libtool-%{version}
+
+%build
+CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+  CPUS=1
+fi
+CFLAGS="$RPM_OPT_FLAGS"			\
+./configure \
+    --prefix=%{_prefix} \
+    --infodir=%{_infodir}
+make -j$CPUS
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{_libdir}/*a
+rm -rf $RPM_BUILD_ROOT%{_infodir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/libtool
+%dir %attr (0755, root, other) %{_datadir}/aclocal
+%{_datadir}/aclocal/*
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+
+%changelog
+* Tue Aug 22 2006  <[email protected]>
+- fix %files attributes
+- move to /opt/jdsbld by default
+* Wed Aug 16 2006  <[email protected]>
+- add missing deps
+- bump to 1.5.22
+* Wed Sep 07 2005  <[email protected]>
+- update to 1.5.20
+- fix bug where convenience libs are comma separated after -z allextract
+* Fri Sep 02 2004  <[email protected]>
+- remove unpackaged files
+* Tue Jun 14 2005  <[email protected]>
+- update to 1.5.18
+* Thu Jun 09 2005  <[email protected]>
+- update to 1.5.14
+* Sun Sep 05 2004  <[email protected]>
+- enable parallel build
+* Fri Mar 05 2004  <[email protected]>
+- fix %files
+- change the pkg category