CBEgnused.spec
changeset 4 407e0b9732b0
child 7 fe5233293a17
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/CBEgnused.spec	Sun Apr 20 08:19:47 2008 +0000
@@ -0,0 +1,85 @@
+#
+# spec file for package CBEgnused
+#
+# Copyright 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%include CBE.inc
+
+Name:			CBEsed
+Version:		4.1.5
+License:		GPL
+Distribution:		JDS CBE
+Vendor:			Sun Microsystems, Inc.
+Summary:		JDS CBE: GNU Stream Editor
+Source:			ftp://ftp.gnu.org/gnu/sed/sed-%{version}.tar.gz
+Patch1:			sed-01-gettext.diff
+Patch2:			sed-02-portability.diff
+BuildRoot:		%{_tmppath}/%{name}-%{version}-build
+SUNW_BaseDir:		%{_prefix}
+SUNW_Category:		JDS,CBE,application
+SUNW_Rev:		@CBE_VERSION@
+%include default-depend.inc
+
+
+%prep
+%setup -q -n sed-%version
+%patch1 -p1 -b .patch01
+%patch2 -p1 -b .patch02
+
+%build
+CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+     CPUS=1
+fi
+
+export CFLAGS="%optflags -D_LARGEFILE64_SOURCE"
+export LDFLAGS="%ldflags"
+
+glib-gettextize -f 
+libtoolize --copy --force
+aclocal -I config
+autoheader
+autoconf
+
+if test -f mkinstalldirs ; then /usr/bin/true ; else ( echo "#! /bin/sh" ; echo "/usr/bin/mkdir -p \"\$@\"" ) > mkinstalldirs ; fi
+chmod 755 mkinstalldirs
+
+./configure --prefix=%{_prefix}  \
+            --mandir=%{_mandir} \
+	    --infodir=%{_infodir}
+
+make -j$CPUS
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, bin) %{_mandir}
+%dir %attr (0755, root, bin) %{_mandir}/man1
+%{_mandir}/man1/*.1
+%dir %attr(0755, root, bin) %{_infodir}
+%{_infodir}/*
+
+%changelog
+* Sun Apr 20 2008 - <[email protected]>
+- adopt for CBE
+* Wed Oct 31 2007 - <[email protected]>
+- adpot for KBE
+* Sat Jan  6 2006 - [email protected]
+- bump to 4.1.5
+- add patches gettext.diff and portability.diff
+* Tue Nov 14 2006 - Eric Boutilier
+- Initial spec