CBEbison.spec
author xlucas
Fri, 10 Jul 2009 13:16:22 +0000
changeset 43 3074c20eff5a
parent 10 a65a967018ee
permissions -rw-r--r--
2009-07-10 Lukas (Luc) Oboril <[email protected]> * bump yasm to 0.8.0

#
# spec file for package CBEbison
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEbison
License:		GPL
Group:			system/cbe
Version:		2.3
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU parser generator
Source:			ftp://ftp.gnu.org/gnu/bison/bison-%{version}.tar.bz2
URL:			http://www.gnu.org/
SUNW_BaseDir:		%{_prefix}
SUNW_Category:		CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
BuildRequires: %make_dep

%prep
%setup -q -n bison-%{version}

%define INSTALL install -m755 -s
%define INSTALL_DIR install -d -m755
%define INSTALL_DATA install -m644
%define _mandir %{_datadir}/man

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
%if %cc_is_gcc
  export CXXFLAGS="-O2 -Xlinker -i"
  export CFLAGS="-O2 -Xlinker -i"
%else
  export CXXFLAGS="-i -xO3 -xspace -mr -norunpath"
  export CFLAGS="-i -xstrconst -mr"
%endif
./configure --prefix=%{_prefix} \
  --libdir=%{_libdir} \
  --mandir=%{_mandir} \
  --datadir=%{_datadir} \
  --infodir=%{_infodir}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
gmake install-man DESTDIR=$RPM_BUILD_ROOT mandir=%_mandir
rm -rf $RPM_BUILD_ROOT%{_libdir}
rm -rf $RPM_BUILD_ROOT%{_infodir}
rm -rf $RPM_BUILD_ROOT%{_datadir}/aclocal

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr(0755, root, sys) %{_datadir}
%{_datadir}/bison
%{_mandir}

%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Tue Aug 22 2006  <[email protected]>
- fix %files attributes
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
- bump to 2.3
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Fri Mar 05 2004 - <[email protected]>
- Included in the CBE, updated accordingly
* Fri Mar 05 2004 - [email protected]
- removed package root def'n
* Thu Mar 04 2004 - [email protected]
- initial version added to CVS