CBEautomake.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 13 1669a54e47a8
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEautomake
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEautomake
Version:		1.10.1
%define am_19_version   1.9.6
Release:		1
License:		GPL
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU automake
Source:			ftp://ftp.gnu.org/pub/gnu/automake/automake-%{version}.tar.bz2
Source1:                ftp://ftp.gnu.org/pub/gnu/automake/automake-%{am_19_version}.tar.bz2
URL:			http://www.gnu.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
Requires: SUNWperl584core
%if %(pkginfo -q SUNWgm4 && echo 1 || echo 0)
BuildRequires: SUNWgm4
%else
BuildRequires: CBEm4
%endif
BuildRequires: %make_dep

%description
GNU automake for the Desktop build environment

%prep
%setup -q -c -n %name-%{version}
bzcat %SOURCE1 | tar xf -

%build
cd automake-%{am_19_version}
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure \
    --prefix=%{_prefix}         \
    --infodir=%{_infodir}
gmake -j$CPUS

cd ../automake-%{version}
CFLAGS="$RPM_OPT_FLAGS"			\
./configure \
    --prefix=%{_prefix}         \
    --infodir=%{_infodir}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
cd automake-%{am_19_version}
gmake install DESTDIR=$RPM_BUILD_ROOT
cd ../automake-%{version}
gmake install DESTDIR=$RPM_BUILD_ROOT

mkdir -p $RPM_BUILD_ROOT%{_datadir}/aclocal

# make aclocal always look for macros in /usr/share/aclocal
test "%{_datadir}" = "/usr/share" || \
    echo "/usr/share/aclocal" > $RPM_BUILD_ROOT%{_datadir}/aclocal/dirlist

rm -rf $RPM_BUILD_ROOT%{_infodir}

# make automake-1.10 the default
cd $RPM_BUILD_ROOT%{_bindir}
rm automake
ln -s automake-1.10 automake
rm aclocal
ln -s aclocal-1.10 aclocal

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/aclocal-*
%{_datadir}/automake-*
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/automake
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*

%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency, create aclocal symlink
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Mon Mar  3 2008 - [email protected]
- bump to 1.10.1
- create automake symlink explicitely
* Mon Mar 26 2007 - [email protected]
- bump to 1.10 but include 1.9.6 too
* Tue Aug 22 2006  <[email protected]>
- fix %files attributes
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
* Tue Oct 18 2005 - <[email protected]>
- add /usr/share/aclocal to the default search path
* Wed Aug 31 2005 - <[email protected]>
- update to 1.9.6
* Sun Sep 05 2004 - <[email protected]>
- enable parallel build
* Fri Mar 05 2004 - <[email protected]>
- fix %files
- change the pkg category