CBEcmake.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 39 24e4e432ccf2
child 42 923c6af7c39e
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEcmake
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEcmake
Version:		2.6.3
Group:			system/cbe
License:		BSD
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: Cross platform make system
Source:			http://www.cmake.org/files/v2.6/cmake-%{version}.tar.gz
URL:			http://www.cmake.org
Patch1:			cmake-01-SunOS.cmake.diff
Patch2:			cmake-02-FindGettext.cmake.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
Requires:		SUNWlibC
BuildRequires:		%make_dep

%prep
%setup -q -n cmake-%{version}
%patch1 -p1
%patch2 -p1

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

test -z "$CC" && export CC="/usr/bin/cc"
test -z "$CXX" && export CXX="/usr/bin/CC -norunpath"

./configure --prefix=%{_prefix} \
	    --bindir=%{_bindir}	\
	    --libdir=%{_libdir}	\
	    --mandir=%{_mandir}

export CFLAGS="%optflags"
export CXXFLAGS="%cxx_optflags"

# disabled parallel build as it appears to break occasionally
gmake

%install
rm -rf $RPM_BUILD_ROOT
gmake DESTDIR=$RPM_BUILD_ROOT install

#### Grrh terrible
mv $RPM_BUILD_ROOT%{_prefix}/doc  $RPM_BUILD_ROOT%{_prefix}/share
mv $RPM_BUILD_ROOT%{_prefix}%{_prefix}/share/man $RPM_BUILD_ROOT%{_prefix}/share 	
rm -rf $RPM_BUILD_ROOT%{_prefix}`dirname %{_prefix}`
    
%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/cmake-*
%{_mandir}/*
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*

%changelog
* Mon Mar 16 2009 <[email protected]>
- bump to 2.6.3 (fix many issues)
* Fri Feb 20 2009 <[email protected]>
- add specific name for GNU msgfmt > gmsgfmt
* Mon Jan 12 2009 <[email protected]>
- bump to 2.6.2 (KDE 4.2)
* Fri Jul 11 2008 <[email protected]>
- step back to 2.4.8, because 2.6.0 has serious
  issue with RUNPATH settings.
* Tue Jun 24 2008 <[email protected]>
- bump to 2.6.0 (KDE4.1 require)
* Wed Jun 11 2008  <[email protected]>
- update rev, make depedency, use -norunpath with CC
* Fri Apr 18 2008 - <[email protected]>
- adopt for CBE
- bump to 2.4.8
* Thu Nov 1 2007  - <[email protected]>
- adopt for KBE
* Mon Oct 22 2007 - [email protected]
- Bump to 2.4.7
* Mon Mar 19 2007 - [email protected]
- Initial spec