CBEcoreutils.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 20 f8e2b17c8c4f
child 48 7279c3f9140d
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEcoreutils
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEcoreutils
Version:		6.10
Release:		1
License:		GPL
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU coreutils
Source:			ftp://ftp.gnu.org/pub/gnu/coreutils/coreutils-%{version}.tar.gz
URL:			http://www.gnu.org/software/coreutils
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
BuildRequires:          %make_dep

%description
GNU coreutils for the Desktop build environment

%prep
%setup -q -n coreutils-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
export LINGUAS="xx"
%define _mandir %{_datadir}/man
CFLAGS="$RPM_OPT_FLAGS %c99flag"			\
./configure --prefix=%{_prefix} --mandir=%{_mandir}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT%{_libdir}
rm -rf $RPM_BUILD_ROOT%{_prefix}/info
cd $RPM_BUILD_ROOT%{_bindir}
ln -s install ginstall

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/*

%changelog
* Tue Jun 17 2008  <[email protected]>
- create ginstall symlink to install to match SUNWgnu-coreutils
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Mon Mar  3 2008 - [email protected]
- rename to CBEcoreutils (from CBEfileutils) and bump to 6.10
* Tue Aug 22 2006  <[email protected]>
- fix %files attributes
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
* Tue Aug  1 2006 - [email protected]
- add -xc99 (fix from Doug Scott)
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Fri Mar 05 2004  <[email protected]>
- fix %files
- change the pkg category