CBEdiff.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 17 5bfcb9e423cd
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEdiff
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEdiff
Version:		2.8.1
Release:		1
License:		GPL
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU diff
Source:			ftp://ftp.gnu.org/pub/gnu/diffutils/diffutils-%{version}.tar.gz
URL:			http://www.gnu.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
BuildRequires:          %make_dep

%description
GNU diff for the Desktop build environment

%prep
%setup -q -n diffutils-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure \
    --prefix=%{_prefix} \
    --mandir=%{_mandir} \
    --infodir=%{_infodir}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install \
    prefix=$RPM_BUILD_ROOT%{_prefix} \
    mandir=$RPM_BUILD_ROOT%{_mandir} \
    infodir=$RPM_BUILD_ROOT%{_infodir}
rm -rf $RPM_BUILD_ROOT%{_infodir}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_mandir}/*

%changelog
* Mon Jun 16 2008  <[email protected]>
- move gendiff to CBEenv.spec
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Tue Aug 22 2006  <[email protected]>
- fix %files attributes
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
* Fri Dec 09 2005  <[email protected]>
- Add gendiff (taken from rpm 3.0.6, license: GPL)
* Fri Sep 02 2005  <[email protected]>
- remove unpackaged files
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Tue Mar 09 2004  <[email protected]>
- initial version