CBEflex.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 10 a65a967018ee
child 44 9d78700fb711
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEflex
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEflex
Version:		2.5.33
License:		BSD
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: flex: a lexical analyser
Source:			http://kent.dl.sourceforge.net/sourceforge/flex/flex-%{version}.tar.bz2
URL:			http://flex.sourceforge.net/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
BuildRequires:          %make_dep

%prep
rm -rf %name-%version
mkdir %name-%version
%setup -q -n flex-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
export CFLAGS="$RPM_OPT_FLAGS %c99flag"
./configure --prefix=%{_prefix} \
  --libdir=%{_libdir} \
  --mandir=%{_mandir} \
  --infodir=%{_infodir} \
  --disable-nls
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake DESTDIR=$RPM_BUILD_ROOT install
rm -rf $RPM_BUILD_ROOT%{_libdir}
rm -rf $RPM_BUILD_ROOT%{_includedir}
rm -rf $RPM_BUILD_ROOT%{_infodir}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/*

%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency, use c99flag
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Mon Aug 21 2006  <[email protected]>
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
- bump to 2.5.33
* Tue Aug  1 2006 - [email protected]
- add -xc99 (fix from Doug Scott)
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Fri Mar 05 2004  <[email protected]>
- fix %files
- change the pkg category