CBEgettext.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 10 a65a967018ee
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEgettext
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEgettext
Version:		0.16.1
License:		GPL
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU gettext
Source:			ftp://ftp.gnu.org/pub/gnu/gettext/gettext-%{version}.tar.gz
URL:			http://www.gnu.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
BuildRequires:          %make_dep

%description
GNU gettext for the Desktop build environment

%prep
%setup -q -n gettext-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
export EMACS=no
CFLAGS="$RPM_OPT_FLAGS"	\
./configure --disable-nls --prefix=%{_prefix}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -r $RPM_BUILD_ROOT%{_datadir}/doc
rm -r $RPM_BUILD_ROOT%{_datadir}/man
rm -r $RPM_BUILD_ROOT%{_includedir}
rm $RPM_BUILD_ROOT%{_bindir}/gettext
rm $RPM_BUILD_ROOT%{_bindir}/msgfmt
rm $RPM_BUILD_ROOT%{_libdir}/*a
rm -r $RPM_BUILD_ROOT%{_datadir}/info
rm -r $RPM_BUILD_ROOT%{_datadir}/gettext/projects
rm $RPM_BUILD_ROOT%{_bindir}/recode-sr-latin

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gettext
%{_libdir}/lib*.so*
%{_libdir}/charset.alias
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/autopoint
%{_bindir}/gettext.sh
%{_bindir}/msgcat
%{_bindir}/msgconv
%{_bindir}/msgfilter
%{_bindir}/msginit
%{_bindir}/msguniq
%{_bindir}/envsubst
%{_bindir}/gettextize
%{_bindir}/msgcmp
%{_bindir}/msgen
%{_bindir}/msgmerge
%{_bindir}/ngettext
%{_bindir}/msgattrib
%{_bindir}/msgcomm
%{_bindir}/msgexec
%{_bindir}/msggrep
%{_bindir}/msgunfmt
%{_bindir}/xgettext
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*
%{_datadir}/gettext

%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, make depedency
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Mon Mar  3 2008 - [email protected]
- bump to 0.16.1
* Mon Aug 21 2006  <[email protected]>
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Sat Oct 02 2004  <[email protected]>
- add %_datadir/gettext to %files
* Sun Sep 05 2004  <[email protected]>
- update to 0.14.1
- build and package the tools
- enable parallel build
* Fri Mar 05 2004  <[email protected]>
- fix %files
- change the pkg category