CBEgnuawk.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 35 4ecd11d36119
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEgnuawk
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEgawk
Version:		3.1.6
License:		GPL
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU awk - pattern scanning and processing filter
Source:			http://ftp.gnu.org/gnu/gawk/gawk-%{version}.tar.gz
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:		CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
Requires: SUNWlibms
BuildRequires:          %make_dep

%prep
%setup -q -n gawk-%version

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

export CFLAGS="%optflags -I/usr/sfw/include -DANSICPP"
export RPM_OPT_FLAGS="$CFLAGS"
export MSGFMT="/usr/bin/msgfmt"

./configure --prefix=%{_prefix}			\
	    --libexecdir=%{_libexecdir}         \
	    --mandir=%{_mandir}                 \
	    --datadir=%{_datadir}               \
            --infodir=%{_datadir}/info
	    		
gmake -j$CPUS

%install
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT%{_prefix}/gnu
rm -rf $RPM_BUILD_ROOT%{_datadir}/info/dir
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libexecdir}
%{_libexecdir}/*
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_datadir}/info
%dir %attr(0755, root, sys) %{_datadir}/awk
%{_datadir}/awk/*
%{_datadir}/info/*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%changelog
* Fri Jul 18 2008 <[email protected]>
- remove locale, prevent to build error on Nevada >= 92
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Sun Apr 20 2008 - <[email protected]>
- adopt for CBE
* Tue Oct 30 2007 - <[email protected]>
- adopt for KBE
- bump to 3.1.6
* Wed Oct 11 2006 - [email protected]
- add postrun scripts for updating the info dir file
* Sun Jan 18 2006 - [email protected]
- rename to SFEgawk; update summary
- remove -share pkg
- make /usr/gnu/bin/awk a symlink to /usr/bin/gawk
* Thu Apr  6 2006 - [email protected]
- Move Build/Requires to be listed under base package to be useful.
* Sun Dec  4 2005 - mike kiedrowski (lakeside-AT-cybrzn-DOT-com)
- Initial spec