CBElibtool22.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 10 a65a967018ee
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBElibtool
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBElibtool
Version:		2.2.4
Release:		1
License:		GPL
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: GNU libtool
Source:			ftp://ftp.gnu.org/pub/gnu/libtool/libtool-%{version}.tar.gz
URL:			http://www.gnu.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
Requires:               SUNWcsl
Requires:               SUNWperl584core
BuildRequires:          %make_dep

%define cc_is_gcc %(test "x`basename $CC`" = xgcc && echo 1 || echo 0)

%if %cc_is_gcc
%define optflags           -O2 -Xlinker -i
%else
%define optflags           -xO4 -i -xspace -xstrconst -mr
%endif

%description
GNU libtool for the Desktop build environment

%prep
%setup -q -n libtool-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
CFLAGS="$RPM_OPT_FLAGS"			\
./configure \
    --prefix=%{_prefix} \
    --infodir=%{_infodir}
gmake -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -f $RPM_BUILD_ROOT%{_libdir}/*a
rm -rf $RPM_BUILD_ROOT%{_infodir}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/libtool
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Tue May 27 2008 <[email protected]>
- bump to 2.2.4
* Tue Aug 22 2006  <[email protected]>
- fix %files attributes
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
- bump to 1.5.22
* Wed Sep 07 2005  <[email protected]>
- update to 1.5.20
- fix bug where convenience libs are comma separated after -z allextract
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Tue Jun 14 2005  <[email protected]>
- update to 1.5.18
* Thu Jun 09 2005  <[email protected]>
- update to 1.5.14
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Fri Mar 05 2004  <[email protected]>
- fix %files
- change the pkg category