CBEsubversion.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 12 af4384a951ad
child 44 9d78700fb711
permissions -rw-r--r--
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEsubversion
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

%define version_apr 1.2.11
%define version_apr_util 1.2.10
%define version_neon 0.25.5

Name:			CBEsvn
Version:		1.4.6
License:		Apache,LGPL,BSD
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: Subversion SCM
Source:			http://subversion.tigris.org/downloads/subversion-%{version}.tar.bz2
Source1:		http://www.apache.org/dist/apr/apr-%{version_apr}.tar.bz2
Source2:		http://www.apache.org/dist/apr/apr-util-%{version_apr_util}.tar.bz2
Source3:		http://www.webdav.org/neon/neon-%{version_neon}.tar.gz
URL:			http://subversion.tigris.org/
Patch1:                 subversion-01-libneon.la.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
Requires: SUNWcsl
Requires: SUNWcsr
Requires: SUNWlibms
Requires: SUNWzlib
Requires: SUNWopenssl-libraries
Requires: SUNWbash
BuildRequires: SUNWopenssl-include
BuildRequires:          %make_dep
BuildRequires: SUNWPython

%description
Subversion source code management system.

%define _mandir %{_datadir}/man

%prep
%setup -q -n subversion-%{version}
bzcat %SOURCE1 | tar xf -
mv apr-%{version_apr} apr
bzcat %SOURCE2 | tar xf -
mv apr-util-%{version_apr_util} apr-util
gzcat %SOURCE3 | tar xf -
mv neon-%{version_neon} neon
%patch1 -p1 -b .patch01

%build
export CFLAGS="%{optflags} -I/usr/sfw/include -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
export CPPFLAGS="-I/usr/sfw/include"
export LD=/usr/ccs/bin/ld
export LDFLAGS="-L%{_prefix}/lib -R%{_prefix}/lib -L/usr/sfw/lib -R/usr/sfw/lib -L$RPM_BUILD_ROOT%{_libdir}"
export PATH=$PATH:/usr/apache2/bin
./autogen.sh
aclocal -I build/ac-macros
autoconf
./configure \
    --prefix=%{_prefix} \
    --exec-prefix=%{_prefix} \
    --disable-static \
    --without-apxs \
    --with-pic \
    --with-installbuilddir=%{_datadir}/apr/build \
    --disable-mod-activation \
    --mandir=%{_mandir} \
    --with-ssl \
    --infodir=%{_infodir}

gmake

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT%{_infodir}

rm $RPM_BUILD_ROOT%{_libdir}/lib*.la

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/apr
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*
%attr (-, root, other) %{_datadir}/locale
%dir %attr (0755, root, bin) %{_mandir}
%dir %attr (0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*
%dir %attr (0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*
%dir %attr (0755, root, bin) %{_mandir}/man5
%{_mandir}/man5/*
%dir %attr (0755, root, bin) %{_mandir}/man8
%{_mandir}/man8/*


%changelog
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Mon Apr 21 2008 - <[email protected]>
- adopt for Desktop CBE
- bump to 1.4.6
* Wed Oct 31 2007 - <[email protected]>
- adopt for KBE
- bump to 1.4.5
* Thu Mar 22 2007 - [email protected]
- Bump to 1.4.3.
- Remove "-I/usr/sfw/include" from CFLAGS and 
  "-L/usr/sfw/lib -R/usr/sfw/lib" from LDFLAGS to build pass
- Nevada bundle neon, Change require from SFEneon to SUNWneon
* Sat Oct 14 2006 - [email protected]
- disable parallel build as it breaks on multicpu systems
- bump to 1.4.0
* Tue Sep 26 2006 - [email protected]
- Add Requires after check-deps.pl run
* Fri Jul  7 2006 - [email protected]
- rename to SFEsubversion
- add info stuff
- add some configure options to enable ssl, apache, https support
- add devel and l10n pkgs
* Sat Jan  7 2006  <[email protected]>
- initial version