CBEyasm.spec
author xlucas
Tue, 28 Apr 2009 09:49:26 +0000
changeset 41 31570364d0f1
parent 33 5a33b8534100
child 43 3074c20eff5a
permissions -rwxr-xr-x
2009-03-16 Lukas (Luc) Oboril <[email protected]> * bump pkgbuild to latest version 1.3.98.4 * add Sun Studio Express 03/09 as known compiler

#
# spec file for package CBEyasm
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:                   CBEyasm
Version:		0.7.1
License:		BSD, Artisitic, GNU GPL2, GNU LGPL2
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: Yet another assembler
Source:                 http://www.tortall.net/projects/yasm/releases/yasm-%{version}.tar.gz
URL:			http://www.tortall.net/projects/yasm/wiki
Patch1:			yasm-01-bin_multi_test.sh.diff
Patch2:			yasm-02-configure.diff
Patch3:			yasm-03-out_test.sh.diff
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
%include default-depend.inc
BuildRequires:          %make_dep


%prep
%setup -q -n yasm-%{version}
%patch1 -p1 -b .patch01
%patch2 -p1 -b .patch02
%patch3 -p1 -b .patch03

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

# the safest way is don't setup optim
export CFLAGS=""
export LDFLAGS=""

./configure --prefix=%{_prefix}		\
	    --bindir=%{_bindir}		\
	    --mandir=%{_mandir}		\
            --libdir=%{_libdir}		\
            --datadir=%{_datadir}	\
            --libexecdir=%{_libexecdir} \
            --sysconfdir=%{_sysconfdir} \
            --enable-shared		\
	    --disable-static
gmake -j$CPUS 

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT


%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755,root,sys) %{_datadir}
%dir %attr (0755,root,bin) %{_mandir}
%{_mandir}/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*


%changelog
* Fri Jun 27 2008 <[email protected]>
- bump to 0.7.1
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency, fix _datadir, _mandir attributes
* Fri Apr 18 2008 - [email protected]
- adopt for CBE
* Sat Apr 05 2008 - [email protected]
- Remove optimization flags, as they yield a broken yasm
* Sat Nov 17 2007 - [email protected]
- adopt for KBE
- bump to 0.6.2
* Mon Apr 30 2007 - [email protected]
- Initial version