CBEyasm.spec
author xlucas
Fri, 18 Apr 2008 08:57:23 +0000
changeset 3 400da8b619bb
parent 2 d4ffc2f221ee
child 7 fe5233293a17
permissions -rwxr-xr-x
fix typo, remove temporary prefix

#
# spec file for package CBEyasm
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:                   CBEyasm
Version:		0.6.2
License:		BSD, Artisitic, GNU GPL2, GNU LGPL2
Distribution:		JDS CBE
Vendor:			Sun Microsystems, Inc.
Summary:		JDS CBE: Yet another assembler
Source:                 http://www.tortall.net/projects/yasm/releases/yasm-%{version}.tar.gz
URL:			http://www.tortall.net/projects/yasm/wiki
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          JDS,CBE,application
SUNW_Rev:		@CBE_VERSION@
%include default-depend.inc


%prep
%setup -q -n yasm-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi

# the safest way is don't setup optim
export CFLAGS=""
export LDFLAGS=""

./configure --prefix=%{_prefix}		\
	    --bindir=%{_bindir}		\
	    --mandir=%{_mandir}		\
            --libdir=%{_libdir}		\
            --datadir=%{_datadir}	\
            --libexecdir=%{_libexecdir} \
            --sysconfdir=%{_sysconfdir} \
            --enable-shared		\
	    --disable-static
make -j$CPUS 

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT


%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755,root,sys) %{_mandir}
%{_mandir}/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*


%changelog
* Fri Apr 18 2008 - [email protected]
- adopt for CBE
* Sat Apr 05 2008 - [email protected]
- Remove optimization flags, as they yield a broken yasm
* Sat Nov 17 2007 - [email protected]
- adopt for KBE
- bump to 0.6.2
* Mon Apr 30 2007 - [email protected]
- Initial version