CBEenv.spec
author laca
Tue, 10 Jun 2008 13:04:19 +0000
changeset 10 a65a967018ee
parent 7 fe5233293a17
child 11 6769bf4088b7
permissions -rw-r--r--
2008-06-11 Laszlo (Laca) Peter <[email protected]> * README: (new) note on building the CBE from svn * CBEant.spec: update rev * CBEautoconf.spec: update rev, gmake dependency * CBEautomake.spec: update rev, gmake dependency, create aclocal symlink * CBEbison.spec: update rev, gmake dependency * CBEcmake.spec: update rev, gmake depedency, use -norunpath with CC * CBEcoreutils.spec: update rev, gmake dependency * CBEcvs.spec: update rev, gmake depedency * CBEdiff.spec: update rev, gmake depedency * CBEenv.spec: update version, create symlinks for [Open]Solaris gnu make, automake, aclocal * CBEflex.spec: update rev, gmake depedency, use c99flag * CBEgettext.spec: update rev, gmake dependency * CBEgnuawk.spec: update rev, gmake dependency * CBEgnused.spec: update rev, gmake dependency * CBElibtool.spec: update rev, gmake dependency * CBElibtool22.spec: update rev, gmake dependency * CBEm4.spec: update rev, gmake dependency * CBEmake.spec: update rev * CBErsync.spec: update rev, gmake dependency * CBEsubversion.spec: update rev, gmake dependency * CBEyasm.spec: update rev, gmake dependency, fix _datadir, _mandir attributes * cbe-install: major rework for Solaris 10, Nevada and OpenSolaris * cbe-remove: remove all 'JDS CBE' and 'Desktop CBE' packages * ext-sources/env.csh: fix unset bug reported by Ben Taylor, where multi-line values break the script * ext-sources/env.sh: fix unset bug reported by Ben Taylor * include/CBE.inc: define c99flag, cxx_optflags, make_dep and change default cbe prefix to /opt/dtbld

#
# spec file for package CBEenv
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEenv
Version:		%{?cbe_version}%{?!cbe_version:0.0}
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: env setup scripts for the Desktop CBE
Source:			env.sh
Source1:                env.csh
Source2:                ld-wrapper
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
%include default-depend.inc

%prep
mkdir -p %name-%version

%define relroot %(echo %{_bindir} | sed -e 's,[^/][^/]*,..,g' | cut -c2-)

%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE0 $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE1 $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE2 $RPM_BUILD_ROOT%{_bindir}
chmod 755 $RPM_BUILD_ROOT%{_bindir}/*

%if %(pkginfo -q CBEautomake && echo 0 || echo 1)
# create the "automake" symlink to automake 1.10 when using the
# Solaris default automake, because it only includes versioned
# entries in /usr/bin
test -f %{?altroot}/usr/bin/automake-1.10 && {
    cd $RPM_BUILD_ROOT%{_bindir}
    ln -s %relroot/usr/bin/automake-1.10 automake
} || {
    echo 'automake-1.10 not found'
    exit 1
}
test -f %{?altroot}/usr/bin/aclocal-1.10 && {
    cd $RPM_BUILD_ROOT%{_bindir}
    ln -s %relroot/usr/bin/aclocal-1.10 aclocal
} || {
    echo 'aclocal-1.10 not found'
    exit 1
}
%endif

%if %(pkginfo -q CBEmake && echo 0 || echo 1)
# create the "make" symlink to gmake when using SUNWgmake
GMAKE=xx
for f in /usr/gnu/bin/make /usr/bin/gmake /usr/sfw/bin/gmake; do
    test -f %{?altroot}$f && GMAKE=$f
done
if [ "x$GMAKE" == xxx ]; then
    echo 'GNU make not found, please install SUNWgmake or CBEmake'
    exit 1
fi
cd $RPM_BUILD_ROOT%{_bindir}
ln -s %relroot$GMAKE make
%endif

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*

%changelog
* Wed Jun 11 2008  <[email protected]>
- update version, create symlinks for [Open]Solaris gnu make, automake, aclocal
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Fri Oct 14 2005  <[email protected]>
- add ld-wrapper
* Mon Sep 06 2004  <[email protected]>
- update version, fix Summary
* Mon May 24 2004  <[email protected]>
- initial version