CBEsubversion.spec
author xlucas
Tue, 15 Dec 2009 11:02:29 +0000
changeset 50 c265167ce53c
parent 49 108dc0f05be7
permissions -rw-r--r--
2009-12-15 Lukas (Luc) Oboril <[email protected]> * CBEcmake.spec: add fix Boost and JNI find modules

#
# spec file for package CBEsubversion
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEsvn
Version:		1.6.6
License:		Apache,LGPL,BSD
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: Subversion SCM
Source:			http://subversion.tigris.org/downloads/subversion-%{version}.tar.bz2
Source1:		http://subversion.tigris.org/downloads/subversion-deps-%{version}.tar.gz
URL:			http://subversion.tigris.org/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:		%{?cbe_version}%{?!cbe_version:0.0}
Requires: SUNWcsl
Requires: SUNWcsr
Requires: SUNWlibms
Requires: SUNWzlib
Requires: SUNWopenssl-libraries
Requires: SUNWbash
BuildRequires: SUNWopenssl-include
BuildRequires:          %make_dep
BuildRequires: SUNWPython

%description
Subversion source code management system.

%define _mandir %{_datadir}/man

%prep
%setup -q -n subversion-%{version}
cd .. && gzcat %SOURCE1 | tar xf -

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
     CPUS=1
fi

export CFLAGS="%{optflags} -I/usr/sfw/include -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64"
export CPPFLAGS="-I/usr/sfw/include"
export LD=/usr/ccs/bin/ld
export LDFLAGS="-L%{_prefix}/lib -R%{_prefix}/lib -L/usr/sfw/lib -R/usr/sfw/lib -L$RPM_BUILD_ROOT%{_libdir}"

./autogen.sh
aclocal -I build/ac-macros
autoconf
./configure \
    --prefix=%{_prefix} \
    --exec-prefix=%{_prefix} \
    --disable-static \
    --without-apxs \
    --with-pic \
    --disable-mod-activation \
    --mandir=%{_mandir} \
    --with-ssl \
    --infodir=%{_infodir} \
    --enable-javahl \
    --with-jdk="/usr/java" \
    --enable-runtime-module-search \
    --disable-mod-activation \
    --without-berkeley-db

gmake 

#-j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
gmake install DESTDIR=$RPM_BUILD_ROOT
rm -rf $RPM_BUILD_ROOT%{_infodir}
rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
rm -rf $RPM_BUILD_ROOT%{_datadir}/apr
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_prefix}/build-1

rm $RPM_BUILD_ROOT%{_libdir}/lib*.la
rm $RPM_BUILD_ROOT%{_libdir}/lib*.a

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, bin) %{_mandir}
%dir %attr (0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*
%dir %attr (0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*
%dir %attr (0755, root, bin) %{_mandir}/man5
%{_mandir}/man5/*
%dir %attr (0755, root, bin) %{_mandir}/man8
%{_mandir}/man8/*


%changelog
* Wed Jul 22 2009 <[email protected]>
- change source location of apr and apr-utils
* Wed Jun 11 2008  <[email protected]>
- update rev, gmake depedency
* Mon Apr 21 2008 - <[email protected]>
- adopt for Desktop CBE
- bump to 1.4.6
* Wed Oct 31 2007 - <[email protected]>
- adopt for KBE
- bump to 1.4.5
* Thu Mar 22 2007 - [email protected]
- Bump to 1.4.3.
- Remove "-I/usr/sfw/include" from CFLAGS and 
  "-L/usr/sfw/lib -R/usr/sfw/lib" from LDFLAGS to build pass
- Nevada bundle neon, Change require from SFEneon to SUNWneon
* Sat Oct 14 2006 - [email protected]
- disable parallel build as it breaks on multicpu systems
- bump to 1.4.0
* Tue Sep 26 2006 - [email protected]
- Add Requires after check-deps.pl run
* Fri Jul  7 2006 - [email protected]
- rename to SFEsubversion
- add info stuff
- add some configure options to enable ssl, apache, https support
- add devel and l10n pkgs
* Sat Jan  7 2006  <[email protected]>
- initial version