CBEenv.spec
author xlucas
Mon, 21 Apr 2008 12:00:42 +0000
changeset 7 fe5233293a17
parent 1 102c9870ef63
child 10 a65a967018ee
permissions -rw-r--r--
2008-04-20 Lukas (Luc) Oboril <[email protected]> * CBEsubversion.spec: update to 'all-in-one' package (inlcuded neon, apr, apr_util) * Use more universal terms - CBEant.spec - CBEautoconf.spec - CBEautomake.spec - CBEbison.spec - CBEcmake.spec - CBEcoreutils.spec - CBEcvs.spec - CBEdiff.spec - CBEenv.spec - CBEflex.spec - CBEgettext.spec - CBEgnuawk.spec - CBEgnused.spec - CBElibtool.spec - CBElibtool22.spec - CBEm4.spec - CBEmake.spec - CBErsync.spec - CBEyasm.spec - default-depend.inc * CBErsync.spec: use %include default-depend.inc instead of Requires direction.

#
# spec file for package CBEenv
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEenv
Version:		@CBE_VERSION@
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: env setup scripts for the Desktop CBE
Source:			env.sh
Source1:                env.csh
Source2:                ld-wrapper
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
%include default-depend.inc

%prep
mkdir -p %name-%version

%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE0 $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE1 $RPM_BUILD_ROOT%{_bindir}
cp %SOURCE2 $RPM_BUILD_ROOT%{_bindir}
chmod 755 $RPM_BUILD_ROOT%{_bindir}/*

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*

%define relroot %(echo %{_bindir} | sed -e 's,[^/][^/]*,..,g' | cut -c2-)

%post
#!/bin/bash
# create the "automake" symlink to automake 1.10 when using the
# Solaris default automake, because it only includes versioned
# entries in /usr/bin
test -f $PKG_INSTALL_ROOT/usr/bin/automake-1.10 && {
    cd $BASEDIR/bin
    ln -s %relroot/usr/bin/automake-1.10 automake
    installf $PKGINST %{_bindir}/automake s
}
# create the "make" symlink to gmake
GMAKE=xx
for f in /usr/gnu/bin/make /usr/bin/gmake /usr/sfw/bin/gmake; do
    test -f $PKG_INSTALL_ROOT$f && GMAKE=$f
done
if [ "x$GMAKE" == xxx ]; then
    # none of the above was found
    echo 'GNU make not found, please install SUNWgmake'
    exit 1
fi
cd $BASEDIR/bin
ln -s %relroot$GMAKE make
installf $PKGINST %{_bindir}/make s

installf -f $PKGINST

%changelog
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Fri Oct 14 2005  <[email protected]>
- add ld-wrapper
* Mon Sep 06 2004  <[email protected]>
- update version, fix Summary
* Mon May 24 2004  <[email protected]>
- initial version