CBEflex.spec
author xlucas
Mon, 21 Apr 2008 12:00:42 +0000
changeset 7 fe5233293a17
parent 1 102c9870ef63
child 10 a65a967018ee
permissions -rw-r--r--
2008-04-20 Lukas (Luc) Oboril <[email protected]> * CBEsubversion.spec: update to 'all-in-one' package (inlcuded neon, apr, apr_util) * Use more universal terms - CBEant.spec - CBEautoconf.spec - CBEautomake.spec - CBEbison.spec - CBEcmake.spec - CBEcoreutils.spec - CBEcvs.spec - CBEdiff.spec - CBEenv.spec - CBEflex.spec - CBEgettext.spec - CBEgnuawk.spec - CBEgnused.spec - CBElibtool.spec - CBElibtool22.spec - CBEm4.spec - CBEmake.spec - CBErsync.spec - CBEyasm.spec - default-depend.inc * CBErsync.spec: use %include default-depend.inc instead of Requires direction.

#
# spec file for package CBEflex
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include CBE.inc

Name:			CBEflex
Version:		2.5.33
License:		BSD
Group:			system/cbe
Distribution:		Desktop CBE
Vendor:			Sun Microsystems, Inc.
Summary:		Desktop CBE: flex: a lexical analyser
Source:			http://kent.dl.sourceforge.net/sourceforge/flex/flex-%{version}.tar.bz2
URL:			http://flex.sourceforge.net/
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
SUNW_BaseDir:		%{_prefix}
SUNW_Category:          CBE,KDE,JDS,application
SUNW_Rev:               @CBE_VERSION@
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%setup -q -n flex-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi
export CFLAGS="$RPM_OPT_FLAGS -xc99"
export MSGFMT="/usr/bin/msgfmt"
./configure --prefix=%{_prefix} \
  --libdir=%{_libdir} \
  --mandir=%{_mandir} \
  --infodir=%{_infodir} \
  --disable-nls
make -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install
rm -rf $RPM_BUILD_ROOT%{_libdir}
rm -rf $RPM_BUILD_ROOT%{_includedir}
rm -rf $RPM_BUILD_ROOT%{_infodir}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/*

%changelog
* Mon Apr 14 2008 - [email protected]
- update deps
- use CBE.inc
* Mon Aug 21 2006  <[email protected]>
- move to /opt/jdsbld by default
* Wed Aug 16 2006  <[email protected]>
- add missing deps
- bump to 2.5.33
* Tue Aug  1 2006 - [email protected]
- add -xc99 (fix from Doug Scott)
* Fri Sep 02 2004  <[email protected]>
- remove unpackaged files
* Sun Sep 05 2004  <[email protected]>
- enable parallel build
* Fri Mar 05 2004  <[email protected]>
- fix %files
- change the pkg category