SUNWgnome-dtlogin-integration.spec
changeset 15009 9cd4a1ffe12d
parent 14410 1d7d0d833e78
child 15011 c181f6833139
equal deleted inserted replaced
15008:e2380bbb5090 15009:9cd4a1ffe12d
     1 #
     1 #
     2 # spec file for package SUNWgnome-dtlogin-integration
     2 # spec file for package SUNWgnome-dtlogin-integration
     3 #
     3 #
     4 # includes module(s): dtlogin-integration
     4 # includes module(s): dtlogin-integration
     5 #
     5 #
     6 # Copyright 2008 Sun Microsystems, Inc.
     6 # Copyright 2009 Sun Microsystems, Inc.
     7 # This file and all modifications and additions to the pristine
     7 # This file and all modifications and additions to the pristine
     8 # package are under the same license as the package itself.
     8 # package are under the same license as the package itself.
     9 #
     9 #
    10 # Owner: laca
    10 # Owner: laca
    11 #
    11 #
    13 # NOTE: If the version is bumped the new tarball must be uploaded to the
    13 # NOTE: If the version is bumped the new tarball must be uploaded to the
    14 #       Sun Download Center. Contact GNOME RE for assistance.
    14 #       Sun Download Center. Contact GNOME RE for assistance.
    15 %define tarball_version 0.37
    15 %define tarball_version 0.37
    16 
    16 
    17 %include Solaris.inc
    17 %include Solaris.inc
    18 %if %option_with_dt
    18 #%if %option_with_dt
    19 Name:                    SUNWgnome-dtlogin-integration
    19 Name:                    SUNWgnome-dtlogin-integration
    20 SourcePackage:           SUNWgnome-dtlogin-integ-src
    20 SourcePackage:           SUNWgnome-dtlogin-integ-src
    21 Summary:                 dtlogin configuration files for the JDS desktop
    21 Summary:                 dtlogin configuration files for the JDS desktop
    22 %else
    22 #%else
    23 Name:                    SUNWgnome-dtstart
    23 #Name:                    SUNWgnome-dtstart
    24 Summary:                 Desktop startup scripts for JDS
    24 #Summary:                 Desktop startup scripts for JDS
    25 Source2:                 dtstart
    25 #%endif
    26 %endif
       
    27 Source3:                 0005.dbus
       
    28 Version:                 %{default_pkg_version}
    26 Version:                 %{default_pkg_version}
    29 Source:                  http://dlc.sun.com/osol/jds/downloads/extras/dtlogin-integration-%{tarball_version}.tar.bz2
    27 Source:                  http://dlc.sun.com/osol/jds/downloads/extras/dtlogin-integration-%{tarball_version}.tar.bz2
    30 Source1:                 l10n-configure.sh
    28 Source1:                 l10n-configure.sh
       
    29 Source2:                 dtstart
       
    30 Source11:                0010.env
       
    31 Source12:                0020.pre-localization
       
    32 Source13:                0060.sockets
       
    33 Source14:                0070.dbus
       
    34 Source15:                0110.fonts
       
    35 Source16:                0120.xrdb
       
    36 Source17:                0210.im
       
    37 Patch1:                  %{name}-01-g11n-migration.diff
    31 SUNW_BaseDir:            %{dtlogin_config_basedir}
    38 SUNW_BaseDir:            %{dtlogin_config_basedir}
    32 SUNW_Copyright:          SUNWgnome-dtlogin-integration.copyright
    39 SUNW_Copyright:          SUNWgnome-dtlogin-integration.copyright
    33 BuildRoot:               %{_tmppath}/%{name}-%{version}-build
    40 BuildRoot:               %{_tmppath}/%{name}-%{version}-build
    34 %include default-depend.inc
    41 %include default-depend.inc
    35 Requires: SUNWgnome-panel
    42 Requires: SUNWgnome-panel
    36 Requires: SUNWgnome-session
    43 Requires: SUNWgnome-session
    37 Requires: SUNWgnome-wm
    44 Requires: SUNWgnome-wm
    38 
    45 
       
    46 %package -n SUNWdesktop-startup
       
    47 Summary:                 Desktop startup scripts for JDS
       
    48 SUNW_BaseDir:		 /
       
    49 %include default-depend.inc
       
    50 Requires: SUNWgnome-panel
       
    51 Requires: SUNWgnome-session
       
    52 Requires: SUNWgnome-wm
       
    53 
       
    54 
    39 %prep
    55 %prep
    40 %setup -q -n dtlogin-integration-%{tarball_version}
    56 %setup -q -n dtlogin-integration-%{tarball_version}
    41 
    57 
    42 bash -x %SOURCE1 --enable-sun-linguas
    58 bash -x %SOURCE1 --enable-sun-linguas
       
    59 
       
    60 %patch1 -p1
    43 
    61 
    44 %build
    62 %build
    45 export LDFLAGS="%_ldflags"
    63 export LDFLAGS="%_ldflags"
    46 export CFLAGS="%optflags"
    64 export CFLAGS="%optflags"
    47 export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
    65 export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
    66 %else
    84 %else
    67 make install DESTDIR=$RPM_BUILD_ROOT
    85 make install DESTDIR=$RPM_BUILD_ROOT
    68 %endif
    86 %endif
    69 
    87 
    70 %if %option_without_dt
    88 %if %option_without_dt
    71 install --mode=0755 -d $RPM_BUILD_ROOT/usr/bin
       
    72 install --mode=0755 %SOURCE2 $RPM_BUILD_ROOT/usr/bin/dtstart
       
    73 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/appconfig
    89 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/appconfig
    74 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/C
    90 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/C
    75 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/[a-z][a-z]*
    91 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/[a-z][a-z]*
    76 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/Xsession*
    92 rm -r $RPM_BUILD_ROOT%{dtlogin_config_basedir}/dt/config/Xsession*
    77 %endif
    93 %endif
    78 
    94 
       
    95 install --mode=0755 -d $RPM_BUILD_ROOT/usr/bin
       
    96 install --mode=0755 %SOURCE2 $RPM_BUILD_ROOT/usr/bin/dtstart
       
    97 
    79 # Create dbus session initialisation script for dtlogin
    98 # Create dbus session initialisation script for dtlogin
    80 %if %option_with_dt
    99 #%if %option_with_dt
    81 install --mode=0755 -d $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d
   100 install --mode=0755 -d $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d
    82 install --mode=0755 %SOURCE3 $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d/0005.dbus
   101 install --mode=0755 %SOURCE14 $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d
    83 %endif
   102 #%endif
       
   103 
       
   104 # rough script number?
       
   105 # 1 - 50: pre configurations
       
   106 # 51 - 100: pre processes
       
   107 # 101 - 150: post configurations
       
   108 # 151 - 200: post processes
       
   109 
       
   110 install --mode=0755 -d $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d/
       
   111 install --mode=0755 -d $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d
       
   112 for FILE in %SOURCE11 %SOURCE12 %SOURCE13 %SOURCE15 %SOURCE16 %SOURCE17
       
   113 do
       
   114   install --mode=0755 $FILE $RPM_BUILD_ROOT/etc/X11/xinit/xinitrc.d
       
   115   install --mode=0755 $FILE $RPM_BUILD_ROOT/%{dtlogin_config_basedir}/dt/config/Xsession.d
       
   116 done
    84 
   117 
    85 rm -rf $RPM_BUILD_ROOT/tmp
   118 rm -rf $RPM_BUILD_ROOT/tmp
    86 
   119 
    87 %clean
   120 %clean
    88 rm -rf $RPM_BUILD_ROOT
   121 rm -rf $RPM_BUILD_ROOT
    89 
   122 
    90 %files
   123 %files
    91 %defattr (-, root, bin)
   124 %defattr (-, root, bin)
    92 %{dtlogin_config_basedir}/dt
   125 %{dtlogin_config_basedir}/dt
    93 %if %option_with_dt
   126 #%if %option_with_dt
    94 %else
   127 #%else
       
   128 #%dir %attr (0755, root, bin) %{_bindir}
       
   129 #%{_bindir}/dtstart
       
   130 #%endif
       
   131 
       
   132 %files -n SUNWdesktop-startup
       
   133 %defattr (-, root, bin)
       
   134 %dir %attr(0755, root, sys) /etc
       
   135 %dir %attr(0755, root, sys) /etc/X11
       
   136 %dir %attr(0755, root, sys) /etc/X11/xinit
       
   137 %dir %attr(0755, root, sys) /etc/X11/xinit/xinitrc.d
       
   138 /etc/X11/xinit/xinitrc.d/*
       
   139 %dir %attr (0755, root, sys) /usr
    95 %dir %attr (0755, root, bin) %{_bindir}
   140 %dir %attr (0755, root, bin) %{_bindir}
    96 %{_bindir}/dtstart
   141 %{_bindir}/dtstart
    97 %endif
       
    98 
   142 
    99 
   143 
   100 %changelog
   144 %changelog
       
   145 * Wed Feb 04 2009 - [email protected]
       
   146 - Add SUNWdesktop-startup for xinitrc.d scripts.
       
   147 - Add patch g11n-migration.diff
   101 * Thu Oct 02 2008 - [email protected]
   148 * Thu Oct 02 2008 - [email protected]
   102 - Bump up tarball to 0.37. Removed dtlogin-integration-02-dbus-launch.diff 
   149 - Bump up tarball to 0.37. Removed dtlogin-integration-02-dbus-launch.diff 
   103   and dtlogin-integration-01-vte-cjk.diff  which are now upstreamed.
   150   and dtlogin-integration-01-vte-cjk.diff  which are now upstreamed.
   104 * Fri Sep 19 2008 - [email protected]
   151 * Fri Sep 19 2008 - [email protected]
   105 - Added dtlogin-integration-02-dbus-launch.diff to fix 6750408.
   152 - Added dtlogin-integration-02-dbus-launch.diff to fix 6750408.