base-specs/esound.spec
branchgnome-2-30
changeset 21096 a842797a1d55
parent 21095 442f80e8a4d6
child 21097 a038d72ac363
equal deleted inserted replaced
21095:442f80e8a4d6 21096:a842797a1d55
     1 #
       
     2 # spec file for package esound
       
     3 #
       
     4 # Copyright 2008 Sun Microsystems, Inc.
       
     5 # This file and all modifications and additions to the pristine
       
     6 # package are under the same license as the package itself.
       
     7 #
       
     8 %define owner yippi
       
     9 #
       
    10 
       
    11 %define OSR LFI#105446 (gnome Exec. summary):n/a
       
    12 
       
    13 Name:         esound
       
    14 License:      LGPL v2
       
    15 Group:        System/Library/GNOME
       
    16 Version:      0.2.41
       
    17 Release:      1
       
    18 Distribution: Java Desktop System
       
    19 Vendor:       Gnome Community
       
    20 Summary:      esound - The Enlightened Sound Daemon
       
    21 Source:       http://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-%{version}.tar.bz2
       
    22 # This patch works with the audiofile-01-uninstalled-config.diff to
       
    23 # allow esound to be built when audiofile isn't acutally installed on the
       
    24 # system.
       
    25 #owner:yippi date:2004-05-07 type:feature
       
    26 Patch1:       esound-01-esd-config.diff
       
    27 URL:          http://www.tux.org/~ricdude/overview.html
       
    28 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
       
    29 Docdir:       %{_defaultdocdir}/%{name}
       
    30 Autoreqprov:  on
       
    31 Requires:     audiofile
       
    32 
       
    33 %description
       
    34 The Enlightened Sound Daemon (ESD or EsounD) is the sound server for
       
    35 Enlightenment and GNOME. It mixes several sound streams into one for output.
       
    36 It can also manage network-transparent audio.
       
    37 
       
    38 %prep
       
    39 %setup -q
       
    40 %patch1 -p1 -b .orig
       
    41 
       
    42 %build
       
    43 %ifos linux
       
    44 if [ -x /usr/bin/getconf ]; then
       
    45   CPUS=`getconf _NPROCESSORS_ONLN`
       
    46 fi
       
    47 %else
       
    48   CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
       
    49 %endif
       
    50 if test "x$CPUS" = "x" -o $CPUS = 0; then
       
    51   CPUS=1
       
    52 fi
       
    53 
       
    54 %if %debug_build
       
    55 %define debug_opt --enable-debugging
       
    56 %else
       
    57 %define debug_opt --disable-debugging
       
    58 %endif
       
    59 
       
    60 libtoolize --force
       
    61 aclocal $ACLOCAL_FLAGS -I .
       
    62 autoconf
       
    63 automake -a -c -f
       
    64 ./configure --prefix=%{_prefix}				\
       
    65 	    --sysconfdir=%{_sysconfdir} 		\
       
    66             --with-esd-dir=%{_prefix}/lib		\
       
    67             --libdir=%{_libdir}                         \
       
    68             --bindir=%{_bindir}                         \
       
    69             --libexecdir=%{_prefix}/lib                 \
       
    70             --disable-audiofiletest                     \
       
    71 	    --mandir=%{_mandir} %{debug_opt}
       
    72 make -j$CPUS
       
    73 
       
    74 
       
    75 %install
       
    76 make install DESTDIR=$RPM_BUILD_ROOT
       
    77 
       
    78 %clean
       
    79 rm -rf $RPM_BUILD_ROOT
       
    80 
       
    81 %files
       
    82 %defattr (-, root, root)
       
    83 %{_bindir}/*
       
    84 %{_libdir}/*
       
    85 %{_sysconfdir}/*
       
    86 
       
    87 %changelog
       
    88 * Sun Jul 26 2009 - [email protected]
       
    89 - Bump to 0.2.41.
       
    90 * Thu Sep 04 2008 - [email protected]
       
    91 - Bump to 0.2.40.
       
    92 * Wed Jul 16 2008 - [email protected]
       
    93 - Bump to 0.2.39.
       
    94 * Fri May 04 2007 - [email protected]
       
    95 - Bump to 0.2.38.
       
    96 * Wed Apr  4 2007 - [email protected]
       
    97 - convert to new style 64-bit build
       
    98 * Wed Mar 15 2007 - [email protected]
       
    99 - Removed adding ccdir to PATH
       
   100 * Wed Feb 28 2007 - [email protected]
       
   101 - need to run automake because the maintainer's version is incompatible with
       
   102   our version of autoconf
       
   103 * Wed Feb 28 2007 - [email protected]
       
   104 - Bump to 0.2.37.
       
   105 * Sun Feb 18 2007 - [email protected]
       
   106 - create (split from SUNWgnome-audio.spec)