SUNWclutter.spec
branchgnome-2-24
changeset 14015 264e975eb35a
child 15178 878f06faf3b6
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWclutter.spec	Wed Nov 26 09:44:39 2008 +0000
@@ -0,0 +1,81 @@
+#
+#
+# spec file for package SUNWclutter
+#
+# includes module(s): clutter
+#
+# Copyright 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: bewitche
+
+%include Solaris.inc
+
+%use clutter = clutter.spec
+
+Name:                    SUNWclutter
+Summary:                 clutter - a library for creating fast, visually rich and animated graphical user interfaces.
+Version:                 %{clutter.version}
+URL:                     http://www.clutter-project.org/
+Source:                  http://www.clutter-project.org/sources/clutter/0.8/clutter-0.8.2.tar.bz2
+SUNW_BaseDir:            %{_basedir}
+SUNW_Copyright:		 SUNWclutter.copyright
+
+%ifnarch sparc
+#the packages are only on x86
+# ============================================
+
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+%include default-depend.inc
+Requires: SUNWgnome-base-libs
+BuildRequires: SUNWgnome-base-libs-devel
+
+%package devel
+Summary:                 %{summary} - developer files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires: %name
+Requires: SUNWgnome-base-libs-devel
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%clutter.prep -d %name-%version/
+
+%build
+%clutter.build -d %name-%version/
+
+
+%install
+%clutter.install -d %name-%version/
+find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
+find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
+
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/gtk-doc
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+
+# endif for "ifnarch sparc"
+%endif
+
+ 
+%changelog
+* Tue Jul  1 2008  [email protected] 
+- Initial build.
+