SUNWgnome-applets.spec
changeset 11368 6f9cfb174a8c
parent 10651 b12e088178d0
child 11370 338c15c66cee
--- a/SUNWgnome-applets.spec	Wed Jan 02 16:53:01 2008 +0000
+++ b/SUNWgnome-applets.spec	Thu Jan 03 05:10:15 2008 +0000
@@ -4,7 +4,7 @@
 # includes module(s): gnome-applets, quick-lounge-applet
 #		      gnome-netstatus, deskbar-applet
 #
-# Copyright 2007 Sun Microsystems, Inc.
+# Copyright 2008 Sun Microsystems, Inc.
 # This file and all modifications and additions to the pristine
 # package are under the same license as the package itself.
 #
@@ -243,83 +243,40 @@
 rm -rf $RPM_BUILD_ROOT
 
 %post -n SUNWgnome-fun-applets
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %postun -n SUNWgnome-fun-applets
-test -x $BASEDIR/lib/postrun || exit 0
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %post -n SUNWgnome-internet-applets
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
+%include scrollkeeper-update.script
 
 %postun -n SUNWgnome-internet-applets
-test -x $BASEDIR/lib/postrun || exit 0
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
+%include scrollkeeper-update.script
 
 %post -n SUNWgnome-intranet-applets
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %postun -n SUNWgnome-intranet-applets
-test -x $BASEDIR/lib/postrun || exit 0
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %post -n SUNWgnome-mm-applets
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
+%include scrollkeeper-update.script
 
 %postun -n SUNWgnome-mm-applets
-test -x $BASEDIR/lib/postrun || exit 0
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
+%include scrollkeeper-update.script
 
 %post -n SUNWgnome-utility-applets
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %postun -n SUNWgnome-utility-applets
-test -x $BASEDIR/lib/postrun || exit 0
-( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
-  echo '/usr/bin/scrollkeeper-update'
-) | $BASEDIR/lib/postrun -b -u -c JDS
-( echo 'test -x /usr/bin/gtk-update-icon-cache || exit 0';
-  echo 'rm -f %{_datadir}/icons/*/icon-theme.cache';
-  echo 'ls -d %{_datadir}/icons/* | xargs -l1 /usr/bin/gtk-update-icon-cache'
-) | $BASEDIR/lib/postrun -b -u -t 5 -c JDS
+%include scrollkeeper-update.script
+%include icon-cache.script
 
 %post -n SUNWgnome-fun-applets-root
 ( echo 'test -x /usr/bin/gconftool-2 || {';
@@ -731,6 +688,8 @@
 # %{_datadir}/omf/gnome-netstatus/*-[a-z][a-z]_*.omf
 
 %changelog
+* Thu Jan  3 2008 - [email protected]
+- use includes instead of inline scripts
 * Thu Oct 11 2007 - [email protected]
 - Fix packaging so that invest applet's python code gets installed.
   Fixes bug #6502277.