SUNWlibsoup.spec
changeset 11789 75666421fd12
child 11805 d949b92ccf42
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWlibsoup.spec	Tue Mar 04 15:53:11 2008 +0000
@@ -0,0 +1,94 @@
+#
+# spec file for package SUNWlibsoup
+#
+# includes module(s): libsoup
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: jefftsai
+#
+%include Solaris.inc
+%use libsoup = libsoup.spec
+
+Name:          SUNWlibsoup
+Summary:       Libsoup is an HTTP client/server library for GNOME.
+Version:       %{default_pkg_version}
+SUNW_Category: EVO25,%{default_category}
+SUNW_BaseDir:  %{_basedir}
+BuildRoot:     %{_tmppath}/%{name}-%{version}-build
+%include default-depend.inc
+Requires: SUNWgnome-base-libs
+Requires: SUNWlibgcrypt
+Requires: SUNWgnutls
+Requires: SUNWlxml
+Requires: SUNWzlib
+Requires: SUNWlibms
+BuildRequires: SUNWgnome-base-libs-devel
+BuildRequires: SUNWlibgcrypt-devel
+BuildRequires: SUNWgnutls-devel
+
+%package devel
+Summary:		%{summary} - development files
+SUNW_BaseDir:		%{_basedir}
+%include default-depend.inc
+Requires:      SUNWlibsoup
+
+%prep
+rm -rf %name-%version
+mkdir -p %name-%version
+%libsoup.prep -d %name-%version
+# cd %{_builddir}/%name-%version
+# cp gtkhtml-%{gtkhtml.version}/mkinstalldirs libsoup-%{libsoup.version}/
+
+%build
+%if %debug_build
+# Omit '-xO4 -xspace' from sparc flags as it crashes libgnome-gtkhtml-editor.
+# See #6461613.
+%else
+%ifarch sparc
+%define optflags           -i -xstrconst -xarch=v8a -mr
+%define cxx_optflags       -i -xarch=v8a -mr -norunpath
+%define optflags64	   -i -xstrconst -xarch=v9 -xcode=pic32 -mr
+%endif
+%endif
+
+export LDFLAGS="%_ldflags -L%{_libdir} -R%{_libdir}"
+export CFLAGS="%optflags"
+export RPM_OPT_FLAGS="$CFLAGS"
+export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
+export PKG_CONFIG_PATH=%{_pkg_config_path}
+%libsoup.build -d %name-%version
+
+%install
+%libsoup.install -d %name-%version
+
+# Verbose deletion to show the dirs being targetted.
+rm -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/libsoup-*
+rmdir $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html
+rmdir $RPM_BUILD_ROOT%{_datadir}/gtk-doc
+rmdir $RPM_BUILD_ROOT%{_datadir}
+
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+
+%changelog
+* Tue Mar 04 2008 - <[email protected]>
+- Initial version created. Splited from SUNWevolution-libs.