SUNWgnome-config.spec
changeset 9397 b16e349d18c5
child 10157 4b183694c352
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWgnome-config.spec	Wed Feb 28 18:57:18 2007 +0000
@@ -0,0 +1,198 @@
+#
+# spec file for package SUNWgnome-config
+#
+# includes module(s): GConf
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner:stephen
+%include Solaris.inc
+%use gconf = GConf.spec
+Name:                    SUNWgnome-config
+Summary:                 GNOME configuration framework
+Version:                 %{default_pkg_version}
+Source:                  %{name}-manpages-0.1.tar.gz
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+BuildRequires: SUNWgnome-base-libs-devel
+Requires: SUNWgnome-base-libs
+Requires: SUNWgnome-config-root
+Requires: SUNWlxml
+BuildRequires: SUNWgnome-component-devel
+Requires: SUNWgnome-component
+Requires: SUNWlibpopt
+
+%package root
+Summary:                 %{summary} - / filesystem
+SUNW_BaseDir:            /
+%include default-depend.inc
+
+%package devel
+Summary:                 %{summary} - development files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+
+%if %build_l10n
+%package l10n
+Summary:                 %{summary} - l10n files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires:                %{name}
+%endif
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%gconf.prep -d %name-%version
+cd %{_builddir}/%name-%version
+gzcat %SOURCE0 | tar xf -
+
+%build
+export CFLAGS="%optflags -I%{_includedir}"
+export CFLAGS32="$CFLAGS"
+export CFLAGS64="%optflags64 -I%{_includedir}"
+export LDFLAGS32="%_ldflags $LDFLAGS"
+export LDFLAGS64="%_ldflags -L/usr/lib/%{_arch64} -R/usr/lib/%{_arch64}"
+%ifarch sparcv9
+export LDFLAGS64="$LDFLAGS64 -L/usr/lib/ST/64 -R/usr/lib/ST/64"
+%endif
+
+export RPM_OPT_FLAGS="$CFLAGS"
+export PKG_CONFIG_PATH=%{_pkg_config_path}
+export MSGFMT="/usr/bin/msgfmt"
+%gconf.build -d %name-%version
+
+%install
+%gconf.install -d %name-%version
+rm -rf $RPM_BUILD_ROOT%{_datadir}/man
+cd %{_builddir}/%name-%version/sun-manpages
+make install DESTDIR=$RPM_BUILD_ROOT
+
+%ifarch amd64 sparcv9
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*.a
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*.la
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/gconfd-2
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/gconf-sanity-check-2
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/GConf/2/lib*.a
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/GConf/2/lib*.la
+%endif
+
+rm -f $RPM_BUILD_ROOT%{_bindir}/gconf-merge-tree
+
+%if %build_l10n
+%else
+# REMOVE l10n FILES
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
+%endif
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/gconftool-2
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/libgconf-2.so*
+%{_libdir}/GConf/2/lib*.so
+%{_libexecdir}/gconf-sanity-check-2
+%{_libexecdir}/gconfd-2
+%ifarch amd64 sparcv9
+%dir %attr (0755, root, bin) %{_bindir}/%{_arch64}
+%{_bindir}/%{_arch64}/gconf-merge-tree
+%{_bindir}/%{_arch64}/gconftool-2
+%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
+%{_libdir}/%{_arch64}/libgconf-2.so*
+%{_libdir}/%{_arch64}/GConf/2/lib*.so
+%endif
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/sgml/gconf/gconf-1.0.dtd
+%{_datadir}/GConf
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/man1
+%{_mandir}/man1/*
+
+%files root
+%defattr (-, root, sys)
+%attr (0755, root, sys) %dir %{_sysconfdir}
+%config %{_sysconfdir}/gconf
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+%ifarch amd64 sparcv9
+%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
+%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
+%{_libdir}/%{_arch64}/pkgconfig/*
+%endif
+%dir %attr (0755, root, sys) %{_datadir}
+%{_datadir}/gtk-doc
+%dir %attr (0755, root, other) %{_datadir}/aclocal
+%{_datadir}/aclocal/*
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/man3
+%{_mandir}/man3/*
+
+%if %build_l10n
+%files l10n
+%defattr (-, root, bin)
+%dir %attr (0755, root, sys) %{_datadir}
+%attr (-, root, other) %{_datadir}/locale
+%endif
+
+%changelog
+* Fri Sep 01 2006 - [email protected]
+- New Manpage tarball
+* Thu Jun 29 2006 - [email protected]
+- don't include gconf-merge-tree.  Now that we're only using the merged
+  data, gconf-merge-tree can only cause trouble
+* Thu Jun 22 2006 - [email protected]
+- Correct LDFLAGS64 to use %{_arch64} and move sparc-specific settings to
+  a %ifarch sparcv9 section.
+* Sun Jun 11 2006 - [email protected]
+- change group from other to bin/sys
+* Wed May 10 2006 - [email protected]
+- merge -share pkg(s) into the base pkg(s)
+* Tue Sep 20 2005 - [email protected]
+- delete unpackaged files or add them to %files
+* Tue Sep 06 2005 - [email protected]
+- fix the 64-bit build
+* Fri Sep 02 2005 - [email protected]
+- remove unpackaged files
+* Sat Oct 02 2004 - [email protected]
+- added %pkgbuild_postprocess
+* Sat Oct  2 2004 - [email protected]
+- Create 64bit libraries for Solaris
+* Mon Aug 30 2004 - [email protected]
+- Bug 5091588 : sman3/4 files should be in a separate devel package
+* Tue Aug 24 2004 - [email protected]
+- set all files in /etc/gconf to volatile, fixes 5090975
+* Sun Aug 22 2004 - [email protected]
+- fix dependencies: don't depend on -devel pkgs
+* Wed Aug 18 2004 - [email protected]
+- Change manpage perms for Solaris integration.
+* Mon Jul 05 2004 - [email protected]
+- Add BuildRequires: SUNWgnome-base-libs-devel
+* Sat Jun 26 2004 - [email protected]
+- Changed install location to /usr/...
+* Thu May 27 2004 - [email protected]
+- added l10n subpkg
+* Thu May 05 2004 - [email protected]
+- removed aclocal files from share since they were already
+  in devel-share.
+* Sun Apr 04 2004 - [email protected]
+- added some missing files to %files
+* Wed Mar 24 2004 - [email protected]
+- Added SGML man page integration
+* Mon Jan 26 2004 - [email protected]
+- initial version added to CVS