SUNWlibcroco.spec
changeset 9397 b16e349d18c5
child 10867 48000eca6fb7
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWlibcroco.spec	Wed Feb 28 18:57:18 2007 +0000
@@ -0,0 +1,90 @@
+#
+# spec file for package SUNWlibcroco
+#
+# includes module(s): libcroco
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: yippi
+#
+%include Solaris.inc
+
+%use libcroco = libcroco.spec
+
+Name:                    SUNWlibcroco
+Summary:                 Cascading Style Sheet (CSS) parsing and manipulation toolkit
+Version:                 %{libcroco.version}
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+Requires: SUNWgnome-base-libs
+Requires: SUNWlxml
+BuildRequires: SUNWgnome-base-libs
+
+%package devel
+Summary:                 %{summary} - development files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%libcroco.prep -d %name-%version
+
+%build
+export PKG_CONFIG_PATH=%{_pkg_config_path}
+export MSGFMT="/usr/bin/msgfmt"
+export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
+export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
+export CFLAGS="%optflags -I%{_includedir}"
+export RPM_OPT_FLAGS="$CFLAGS"
+export LDFLAGS="%_ldflags"
+
+%libcroco.build -d %name-%version
+
+%install
+%libcroco.install -d %name-%version
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/csslint*
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/croco-*-config
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+
+%changelog
+* Sun Jun 11 2006 - [email protected]
+- change group from other to bin/sys
+* Thu May 11 2006 - [email protected]
+- Change build dependency on SUNWgnome-base-libs-share. That pkg is obsolete
+  with files now in the base package.
+* Thu Apr 06 2006 - [email protected]
+- Move the config binary into the -devel package.
+* Fri Feb 24 2006 - [email protected]
+- Update Summary.
+* Fri Feb 24 2006 - [email protected]
+- Update Summary.
+* Mon Feb 20 2006 - [email protected]
+- Update Build/Requires after running check-deps.pl script.
+* Tue Sep 13 2005 - [email protected]
+- Now use libcroco version number.
+* Wed Jul 27 2005 - [email protected]
+- Created.